Close

1999 Lexus LX470 Questions

Get answers to questions about your 1999 Lexus LX470 at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
22
questions

Coming down the interstate, the vehicle suddenly cut off. It will turn over when key is turned but will not start.

once I remove the key from the ignition switch, the notification starts to blink, it does so even after I lock the car.

When I move the gear to drive, a gong sound is heard, I think from the back. What could cause this?

The check engine light bulb is out and needs to be replaced to pass inspection. The bulb itself has gone bad. Thanks

with a beeping sound --all lasted a few minutes and then stopped. This usually happens at the first start of the day and then doesn't happen again.

can I drive my 2003 Lx470 on a short trip of approx. 1500 miles with a bad O2 sensor, waiting on a manifold to be shipped due due bolts on sensors with corrosion

told by my trusted mechanic, unable to remove sensor due to corrosion/rusty bolts, might need to replace pipe which includes a cat.---- cost may be $700 compared to much cheeper if only the o2 sensor comes out

even after i replaced it it has noise when i checked it while engin is running my belt is burning did any body know why

into overdrive

squirt in some carb cleaner past the intake, she fires up but not getting fuel so stops running?

I think it is the low beam

I was told by one of the express oil companies that after 200,000 there was no need to change the transmission fluid....this has been a great vehicle and I hope to keep it much longer but I am feeling almost a drag in the rear end when I accelerate after a full stop

When I turn the radio up at all for there to even be a small amout of bass. The Lcd on the radio will flash and the speaker will start skipping really really fast so it sounds like crap. You cant even hear a word before it skips. I would of thought a speaker has busted but all of them do it and it happend all at once. And the radio flashes also. So any help?? oh also the spark plug is working good.

Got oil change yesterday, pulling out of shop when turn all the way its stop will not move
At slow speed ride like bumpy any one knows what’s wrong? Please