Close

2004 Jaguar X-Type Questions

Get answers to questions about your 2004 Jaguar X-Type at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
53
questions

had right side front strut assembly put in after it exploded now my car will not stay up

After car has set awhile usually low speed

Sometimes it drives ok but after 30 minutes it revs and the caution endicater comes on I turn the car off and back on it drive again then do the same things and I'm losing power I know I need a full tune up so can That be the cause

It will overheat within a few mins if driving, sitting it will overheat within 15-20 mins. I have replaced the thermostat. I don't see any leaks

Under 100,000 miles? between 100,000 - 150,000 miles? Or over 150,000 miles?

Had rotors pads and calipers changed. After driving for a few miles noticed vehicle engine dragging to keep speed. Vehicle was unable Touro forward or reverse without using gas. Seems all wheels calibers are engaged. ABS system checks out fine with code reader . What makes it worse is the problem is intermittent. Any ideas be helpful

just replace rear wheel bearing drivers side and got ABS, engine light on and DSC system fault;is anyone out there have answer how to clear this codes please?

When I pull the hood release inside the cabin only one hood release works

The mech also stated my cooling fan module is bad. Fan contiues to run when car is off. I just had a tune up and gaskets replaced cost 800.00 now they say I need the above and a water pump, for around another $3,000 does that sound correct? The car has 95,000 miles on it.

Heard it could maybe be a tcm module? How do I cure this problem?

It was cold this morning 15 degrees, when I returned from work around noon it had warmed up a bit so I tried starting the car again and it idled fine. It didnt red line itself like it did to my wife just 6 hours earlier? What ales this thing?