It goes almost to the floor before it catches.

Truck cranks but will not catch.

my front brakes locked up on me, but after about 20 mins of sitting, they released and i was able to drive it home as long as i didnt touch the brakes. is the problem the brake caliper and or the caliper hose or is the problem in the master cylinder?

Need to know the name of the part that splits the brake line into F and R (front and rear.) right under the master cylinder.

I found out u need a new Combination Switch but too expensive and easier this way. Ive blown a couple fuses trying a couple wires and cant affor any more blown fuses.

It leaks oil when running

engine runs great untill thermostat opens up. then begins to "chug" and loose power to the point it dies. BUT! if you shut the key off (while rolling in neutral) and wait a couple seconds and start the motor again it runs great for a minute or so and does it again. i believe its a vaccume problem of some sort. not sure where to start looking.

is it short on coil side of fuse? runs fine if unpluged altenator. then blows when alternator is pluged back in. the two little wires out of back of alternator.

Clutch went out

My clutch feels fine it has pressure when you push it to the floor, and it feels like it is shifting through the gears but when i try to drive nothing happens almost like it is stuck in nuetral why wont it take off?

My isuzu truck when I turn the truck on the lights on dashboards stays on ,all gauges lights and today it die on me I jump start it and ran but this every 1/4 mile I check battery volts and read 11.30 volts is there a relay that controls charge or is the alternator,.

My truck used to stall after 30 minutes of driving. It drove very well, but now it will not start. It turns over but doesn't start.

my 1986 isuzu p'up diesel has a hose with a plug hose clamped in the end of it that sticks up from where the oil filter is screwed in. I was driving along when I heard a pop and and pulled over to see that the plug had shot off. I put the plug back in and hose clamped it, added some oil and started it back up. I pulled over after about a mile to check on it and saw that the hose had swelled up around the plug, but the plug stayed in all the way to my house. What could cause the build up of pressure?

Orig owner w 320K miles on great work horse truck. Broke L torsion bar on a rock, and can not find a replacement part. Can anyone make one, or repair the original? I want to restore it.