Instrument Cluster Displays May Lose Pixels on Mercedes-Benz CLK55 AMG

The instrument cluster display may lose pixels and need replacement. However, if the back lighting bulbs for the odometer display in the center of the cluster burn out, they can be replaced.

RepairPal Verified
Average mileage: 98,707 (48,000–200,000)
2 model years affected: 2001, 2002
17 people reported this problem
12 people shared problem details
Lose some pixels on time display. Solution - Bought on ebay a set of two ribbon cables with a special solder gun (from Britain) and replaced both cables.
1 person likes thisFlag inappropiate
Clock and temperature displays lost pixels. $20 for new ribbon cables and I fixed it.
a few pixel have gone out in the dash display panel
The pixels are not displaying. However, the center pixels are still working.
Pixels have failed on the RH lower area of the Instrument Cluster
Several pixels are out and I cannot read the time, temperature or gear I am on!
Just bought it, and was messed up.
About five years ago the left cluster (outside temperature)faded out. Now the right side is tarting to fade. Too expensive to fix so just left as is
I bought my AMG with this problem. Both the temperature and time displays don't work. Any ideas how to fix it?
pixels sometimes partialy go out then may return
only temperature pixels disappearing although some days it appears. Dealer says whole panel would need replacing at over $1,000.
lost pixels on temp and clock
Related Items:
While driving I notice this has happened at least 4 times intermittantly. The CD and the radio...

Related Content