Close

2008 Hyundai Tiburon Questions

Get answers to questions about your 2008 Hyundai Tiburon at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
13
questions

The problem is intermittent. It is as if the cars backs off at 3000 rpms. If I change gears at 3000 rpms the car will accelerate fine until I get to 3000 rpms then it loses power again, almost as if its out of gas.

It stalled out on the way to work.i have already replaced fuel pump,coil pack,wires,plugs,cam and crank sensor.still nothing!!!! Spins over,just won't crank....

Both lines to the heating coil are hot. engine coolant is full

I have a 2008 Hyundai Tiburon SE v6 and I'm having trouble with my gears when I shift its a 6 speed manual transmission. I've had problems to where I'm driving and if I stop at a light and put it back in neutral then try to drive of again my gear box won't let me put it into first when I put my clutch in it won't let me go to any gear it locks up and then I kind of just have to fiddle with it until in unlocks and let's me put it in a gear. Once it allows me to put it in a gear I put it back to neutral and put in my first gear. My third gear cranks really bad when I put in the gear at times. And my 6th is somehow getting stiffer. Any help?

All other lights work.

The driver side door doesn't seem to shut tightly any more and the "door open" alarm goes off and the inside lights go on when I make a left turn.

i took out my Kenwood stereo and installed a Kenwood DX371 display, but for some reason my dashboard lights won't turn on or the center console lights.

Unfortunately, I messed up my own car. While fishing a wire through the firewall for stereo equipment my fish wire caught on some small orange wires in the wire harness. One particularly was pulled pretty hard. I want to know where these wires run to and from in order to fix and trouble shoot it properly.
It has caused the car to hold an idle of 3000rpm when I stop or slow down making it impossible to gear down. The idle returns to normal with a quick half pump on the accelerator.

I believe the crank shaft broke and I need to just replace the whole motor.

Noise sounds like a bathtub full of water. When brakes are applied water sloshes back and forth. What is the cause?

What would cause this issue? It some time goes above 4k or 5k to get to 80 mph

I have replaced the clutch and flywheel and have gotten the bellhousing back on...partially. I have the two top bolts in and the throwout bearing is seated on the clutch lever properly. I cannot seem to get it seated though. Any tips or tricks would be greatly appreciated.

How much air pressure is required for pumping into a Tiburon's tire?