Close

1999 Hyundai Sonata Questions

Get answers to questions about your 1999 Hyundai Sonata at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
28
questions

cannot locate under the dash near the fusebox and relay location which are joined
my signals and hazards don't work atall most of the time but occasionally will blink 2 or 3 times and stop

While I dive it its shaking too

I had it checked by a shop that yes my solenoid is bad and needs to be replaced, so I'm gonna replace them all, but where are they? Is it difficult to get to? I can't find anything online to show if it's a simple fix or not

I had it checked by a shop that yes my solenoid is bad and needs to be replaced, so I'm gonna replace them all, but where are they? Is it difficult to get to? I can't find anything online to show if it's a simple fix or not

tried 2 different ones. Did not work. Any suggestions? Catalyst & 02 sensor not ready. Should I unplug the ECU as mentioned to someone else?

When the car runs until warm it shuts down and also when driving if I push on the gas pedal it Willie power

its it the alternator going out

it also has a low shortage of power which prevents windows from opening or clock in car to stay on.this vehicle uses up gas up to 3-4 times a week to refill tank

when replacing the heater core do you have to remove the freon or just the antifreeze?

transmission filter location

I have a 99 Sonata GLS, 2.0 6 cyl. I took it to the shop with what I thought was a transmission slipping issue. After several hours of their tech checking every tuneup item (compression, timing, etc.) they said that the front 3 cyl were not firing and that it must be the ECM chip.
I took it to the dealership and they said it's never the ECM but usually a tuneup item. They ran the same checks and 2 days later said it was the ECM. They finally get the right one in and it did not fix the problem. They are at a loss now and consulting with "Hyundai Specialists" which I assume means the manufacturer. I believe he said that the injectors are working on the front now, just not firing.
Anyone seen this?

I changed my altenator charged real good toom it for a test drive and after a few minutes of driving I lose gages no rpm's or speedometer but the car stays runnin I know I have speed sensor out but that shouldnt cause this to happen

I changed my altenator charged real good toom it for a test drive and after a few minutes of driving I lose gages no rpm's or speedometer but the car stays runnin I know I have speed sensor out but that shouldnt cause this to happen

I opened the trunk reached under and tried to turn the bulb but it won't budge. any suggestions