Close

2003 Hyundai Santa Fe Questions

Get answers to questions about your 2003 Hyundai Santa Fe at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
154
questions

Could anybody give me an idea on how much it would cost to have a garage repair the offside tone ring. could I do it myself without having to remove the drive shaft? any advice would be grateful, thanks

changed timing&balance belts both catalytic converters,fuel pump strainer,coil packs,maf,cam sensor. could it be purge sensor

I just bought this car and was told it was AWD. I noticed it is 4WD. My car feels like it is dragging or like a wheel or brake is locked and when driving at about 35 - 40 MPH it sometimes gives a bucking feeling. I went in the manual to see if I needed to do something special with the 4WD that might be causing the problem. All the manual talked about is the indicator light that should come on when I turn the key on. Neither this or a TCS light come on. I am scared to drive my vehicle if there is something wrong with either of these systems and now that I notice the lights not coming on, I think there must be something wrong with it for sure.

for about 6 mos, I believe I have had no cold air from air conditioner. there is no Freon at all. thank you for any information you may have.

the engine will turn over but it won't fire, it did this a bit , at first, if i turned the key off and tried it again it worked, but now i went to start it and it turns over but won't fire> coil?, maybe fuel pump maybe? i don't know

Oil cooler for transmission oil has a slight leak and cannot be repaired. How long to replace it? thanks...

the abnormal loud rough ear piercing noise seems to not be as obvious when driving a idle speed, when in neutral or at a stop the noise is very obviously loud and saounds sick or the engine is about to fall out. rough loud abnormal noise started about 5 days ago. help!!!!!!!!!!!

do i bneed to see my oikl chgr

Can I or should I replace that air compressor with a used/rebuilt? Currently have between 105k and 106k miles. Meticulously maintained.

Car was running fine until without warning, will not start. Battery good, fuses checked inside & under hood, started good. Hear clicking noises under dash when trying to turn on ignition.

just noticed this morning. 2 days ago I filled up my gas tank and overfilled it accidentally. not sure if that would have anyting to do with it or not. car is running fine, just has this leak?

The day before, everything was working fine and I've no indication prior to this incident that anything was wrong with the transmission.

I haven't had any indications before this happened that anything was wrong with the transmission.

whe i first started to work on the car use to start, but it didnt have power. i check the catalytic converter and it was mess ut(no flow was going throught it) i change it, car drove good for about 5 min then the same problem, right after car warm up. i change the timing belt and did a tune up. car drove good really smooth for about 5mins again then the same proble. i try to do a induction service. now the car dont even start. i check the gas and the spark it has both gas and spark. any one have an idea what could be the problem?

I checked the manual book and doesn't provide any real troubleshooting information. I was driving and the heat just cut out and has not been on since. please contact me for more info as to what the problem might be.