101
questions

i just put a clutch in my 2002 hyundai elantra gls as i was drivering down the road it just died stopped running i could not get it started it was not getting fire so i changed the relay to the fuel pump. then it started next day it done the same thing whats wrong ?

How do you change transmission filter on 2002 hynda alantra

At Idle the engine idle fluctuates. It goes from a good idle to a very fast one while at a stop. There is a loss of power when the accelerator is pushed, a slight hesitation.

Yesterday I was driving and all of a sudden my gas pedal lost all spring, and it barely moves. This has caused very slow acceleration. My check engine light did not come on, and it does not seem to be anything else wrong.

do I have to press start button on remote more then once, no instructions came with car.

Yesterday night my car battery went dead . I got somone to give me a JUMP , but it wouldn't stay charged for me to get to my house. People keep telling me it could be my alternator . I just feel like I need a new battery . Can anyone help . I have to be back at work Tuesday . Everything came back on like my radio, and windows are able to roll donw after I done had it off for a little while. Then my headlights and ALL lights around my car start to fade out.

recommended by my mechanic a month ago in Santa Cruz, CA 95060.

Search Results for "I HAVE A 2002 HYUNDAI ELANTRA GLS , AND I WENT TO THE CAR WASH THE OTHER DAY AND AFTER I WAS DONE I TRIED TO START MY CAR, AND IT WOULDNT START. SO THEN I GOT A JUMP TO SEE IF IT WOULD START , AND STILL NO START. THEN GOT ANOTHER JUMP AND IT WOULDNT START. SO I TOWED IT HOME. I TOOK THE BATTERY TO THE AUTO STORE TO HAVE IT TESTED AND MY BATTERY IS LIKE NEW THE MAN SAID . AND THERE'S GAS IN THE CAR SO I DONT KNOW WHAT COULD BE WRONG. PLUS WE CHECKED ALL THE FUSES AND EVERYTHINGS OK. IM THINKING MAYBE THE ALTERNATER, STARTER, OR FUEL PUMP. PLEASE HELP , WHAT DO I TRY NEXT???"::

Now the other headlight is not working either. I checked the fuse under the hood and it looks good. Could it be a relay?

I can lock door with transponder but then I can not unlock to get into car. I have to use the key to get in and that causes the alarm to go off. The light goes on with the transponder when it locks but does not when try to unlock. Have changed battery. I have two keys with transponders and the same thing happens with both.

When having to stop or slow down before going uphill, my car loses speed. Even when I press the gas pedal to the floor, it will not get passed 40 mph. Otherwise, the car drives great. The check engine light is on, but had it checked out and it is on because of an Emission issue. Does the problem of loses speed going uphill mean I need to replace the transmission ?

I've managed to replace my brake light switch it worked fine for a few hours but they came back on, I don't have a check engine light on if that makes a difference and stayed on please help

I have a 2002 Hyundai Elantra 2.0. In the cold, my car starts fine usually with the engine turning over once before firing. In the warmer weather, I have to crank it usually 4 or 5 times before the car starts. Sometimes it doesn't start and just sputters.On those instances I try it again and usually the same result. It wants to start but just sputters and almost seems to flood out. I sit for about 30 seconds and crank it again and it starts right away. I've been paying close attention to the sound the fuel pump makes when I turn the key to the "on" position but don't crank it and on the first attempt, I hear a high pitch humm and then a low pitch. I shut the key off and then to on again and a low pitch hum all the way through it cycling. It seems like a fuel supply issue but I'm not sure. I am going to replace the plugs and wires first but once the car runs it idles fine and runs fine on any road or highway no matter what the speed which makes me think its not the fuel pump. Almost like the fuel is draining back to the tank and when the pump cycles at first it is dry of fuel and then starts pumping when it hits the low hum. I have had a check engine light for a while due to an O2 sensor but have never had starting issues due to tthat. Could it be the pump? or soemthing else? Let me know what you think.

The car makes a roaring sound when I drive but runs quietly when idle