292
questions

What kind of parts are you using. I can get Iridium plugs with a lifetime warranty for $12.99 per plug =$78.00 for 6. (Pulstar) You were show high end at $108. On the low end I can get them for $6.99 (Iridium) = $42.00

The interior cabin feels like the car is in a wind tunnel when travelling speeds above 30 KM/H. I have recently done tire rotation,balancing and also have changed the rotors.

Please help.

I called Napa and got a price of $70.00 which is what the Repair Man charged me. However, your estimate shows a low price of $ 29.00. I was curious where this price would have come from.

Can this be true?

high voltage on ip line bank one sensor one

what do i need

i cant operate the climate control from the nav screen.it says please restart engine to operate climate control>its works manually but when i want to operate it from the nav screen it brings that message.all other things work on the nav screen but its just the climate control thats not operating.pls help

Car can crank normally but won't start.

The car sputtered till it stopped all together. It will turnover no problem but will not crank. I checked fuses but i think it is the fuel pump.

i felt like my car fell an made horrible noise when in gear to drive

its a transmission part

The TCS light has come on like this for almost 2 years.I pull over turn car off it goes off it was ok for a long time. Now I just had Transmission replaced and the light won't go off at all now. Can this do further damage to my car. I keep returning my car to Amco to fix the transmission it keeps failing on me could it be the TCS they told me to go back to dealership so have a diagnostic scheduled today but wants some questions answered before I get hit with another monster bill.

when it reaches 3000 rpm it studders up and down

In leaving the dealership following the 60,000 service, my '06 Kia Amanti seemed out of timing and has not run smoothly since that time. Mechanics have taken it apart, checked everything and now feel it may be the tensioner. My feeling is it drove smoothly when I brought it in, but has been jerky, not smooth, since the service.

The engine has a pinging, at time it sounds like tiny bells ringing. It is always while the cars is in drive. And It can be heard at crawling low speed but also once I accelerate. Once the engine is warmed up (at time 1/2 hours), it appears to diminish. I don't hear it while in park idling.