267
questions

Pull fuse 13 on pass side light off

What could be the of the squealing on my 99 Honda Accord when I'm driving it sounds like the rotors or bake pads going bad but I can't tell the rotors seemed smooth no bad dings or scratches in them. Even when I am going 10 mph I can hear the squeal when the wheels turn though. What am I missing?

I have been clearing codes. First it was EGR, E VAP and misfire #2. We cleaned the EGR, I am looking for a canister to do the E VAP and the misfire so far, has stayed clear. The E VAP is back along with the po325. Are these two codes related? When I do the E VAP will the po325 turn off? I am thinking I should do the E VAP first, clear the codes and see what happens...before I go the $100.00+ for a new knock sensor.

I had the radiator replaced about 1 year ago and the indicator stopped working shortly afterwards. It appears to be 1 wire under the distributor cap, but goes into the wire bundle that is all enclosed. Any suggestions?

I'm getting a click, but no other sound or action. Radio/windows still work. It happened intermittently for 2 days and now just won't start.

I have an odd difficult problem.

As of late, the car has been difficult to start. When I turn the key in the ignition, the car sputters (the same sound that when your car is on and you turn the key further in the ignition) and sometimes will not start, but everything lights up. Sometimes it will take 10 minutes of doing this before the car starts. Sometimes there's no wait at all. Key will turn all the way, sometimes with just the sputtering and then starting, sometimes just the sputtering and other times just starts right away. When it start, there's no delay or slow clicking noise at all.

I'll be bringing this to the dealer on Wednesday for an airbag recall and will be mentioning the problem (obviously), but i was curious if anyone else has encountered this problem or is familar with this, and if so, if anyone knows what kind of ballpark I'm looking at to get this fixed. Thanks!

I just noticed a drop or two of fluid leak on the floor of my garage. It appears to be amber colored. How does one diagnose this issue? Is it power steering fluid, brake fluid, oil, or transmission fluid. My car is an automatic.

This leaks seems to be coming from behind the rubber foot rest that is attached to left side of the foot well. It leaks when the car is standing still or moving. I need to get a solution to fix this problem. Thanks.