» »

Reviews for GMC Yukon Denali years:

  1. (2)
  2. (2)
  3. (0)
  4. (3)
  5. (4)
  6. (3)
  7. (14)
  8. (2)
  9. (1)
  10. (1)
  11. (3)
  12. (0)
  13. (1)
  14. (0)
  15. (1)

Owners' Reviews

2004 GMC Yukon Denali Reviews and Owner Comments

 
2004 GMC Yukon Denali
3 Reviews
Write Your Review
Overall Score (3 reviews)
  • Body, Interior & Misc.
  • Engine
  • Brakes
  • Exhaust & Emissions
  • Drive Train
  • Heating & Air Conditioning
  • Electrical & Lights
  • Suspension & Steering
2004 GMC Yukon Denali Owner Reviews (3 reviews)
  • 2004 GMC Yukon Denali
    Visitor, Englewood, CO, December 28, 2012 09:53
    Dear Hempsted NY. You and I must have the exact same Denali. Every problem you listed is identical to the problems I am having. I thought for years, my truck was rock solid. My radio blacks out then recovers on its own. My right front tires wear strangely and my brakes were recently changed, pads and rotors now, I don't trust my brakes....waaay too spongy for my liking. I guess thats GMC telling us to buy a new one. I had planned to put 200k on the odometer, but not so sure it will make it another 100k miles. Forgot to mention, my autoride system is now malfunctioning. It self levels every 5 minutes or so on flat roads when I am not pulling anything. The compressor motor cycles on and off for no reason. I recently had in shop to replace right front hub bearing, they serviced my front differential, now it leaks fluid and it did not before. I took back to shop and they are trying to diagnose the leake after I have forked over $1,300 already. I have a 2000 GMC Sonoma had a rear differential fail two months ago, which is in the shop now for a transmission rebuild, GMC is causing me to rethink going back to Nissan.
    Flag This
  • 2004 GMC Yukon Denali
    Visitor, Hempstead, NY, August 09, 2012 17:43
    my vehicle is in good shape but it have been given me the next list of problems 1 the right front wheel is worn, and i have seen many denali's whit that problem 2 the trany started shifting on his own 3 after the first time i changed the brakes it haven't been the pedal is always spongy the only time it get's hard is when i take it to the car wash after a couple of days it get back spongy 4 sometimes im driving everything goes black nav, radio and DIC goes black and then after a minute comes back 5 the latest is when i take the key out and shut the door it suppose to turn of i have to close and open the door for it to go of
    Flag This
  • 2004 GMC Yukon Denali
    too many car problems, Garrett, IN, August 11, 2010 19:07
     Enthusiast
    I bought mine used w/about 99,000 miles on it. It has never left me stranded or not started, etc. But i've had it nearly 8mos now and have only put about 5,000 miles on it (i also have a 2008 sebring i bought new, that has 52,000 on it already) i do a lot of driving. This Yukon has been in the shop more than on the road! Some of the denali trim is peeling off on the rear and the front quarter panel. When I drove it off the lot, the rear wiper didn't work, by the time they finished screwing up that (finally the used car dealer gave up and took it to a GMC dealer)- my heated seats had quit working and so had my fog lights. Once the wiper was working, the fog lights did too, no such luck on the driver heated seat. The tire sensor monitor fault has shown up since I bought it. The used dealer never did fix those- took it to my chrysler dealer and they fixed them. New brakes and rotors, new grill and headlight assemblies (had been in a wreck the used dealer forgot to mention)- they replaced those items, and the driver side view mirror (mirror shook inside the housing on the interstate- couldn't see behind me), The radio had a CD jambed in it, so they replaced the top CD part. Then I tried to get XM radio and they said my tuner was going out and needed repaired.- so no XM for me. I hit 2 deer within about 1 mile of each other and had the SUV towed to the dealer. When i got it back (2.5 months later- couldn't get a steel reinforcement for the bumper?) the rear wiper didn't work again and now my remote starter didn't work. Remote start was an easy fix, still dealing w/the wiper... RIDICULOUS!!!! Not sure if it was working before or not.. but with all the heat, just tried to turn on the A/C to the rear and it only blows hot air... Anyone considering a used Denali... consider a horse or a bicycle...
    Flag This
Ask a Question