I drove 45 miles the other day and then turned my truck off for about 10 minutes. I tried to turn the truck on and it tried to turnover once and didn't start, I turned the key to the start position about 3 or 4 more times and nothing happened, I waited a second and tried one more time and it started. I drove 60 miles and turned the truck off and it wouldn't start again. I had someone try to jump me off and nothing happened, so the guy suggested that I tap on the starter to see if that was the problem, I tapped on the starter a minute and it started. I drove another 60 miles and the same thing happened. I tried to tap on the starter this time and nothing happened, but I got a flathead screwdriver and touched it to the front of the starter and a piece of medal and it made the starter spark. After touching the starter a few times and it spark and tapping on it a few times the truck started, I drove 60 miles again and shut it off until the next morning. The same thing started to happen again and this time I had someone with jumper cables hooked up to my truck and I tapped on the starter several times and I made the starter spark with the flathead several times and it took about 30 minutes to start. I drove 60 miles and turned it off until today. I tried everything that I did before and nothing happened, I replaced the battery because it has messed up before and it was 7 years old. Still nothing, it won't even try to turn over. Any suggestions?

I changed the rear calipers on my truck and took precautions not to allow air into the system,but i bled the wheels many times and still the brake pedal goes almost to the floor. i have bled brakes on many vehicles but never had this problem.

email pletscher56@gmail.com
user name Richard Whiskey

I need to replace the studs

When I activate my washers, fluid is forcibly blown out the top of the reservoir.
I do get fluid onto the windshield but am losing a ton of fluid out of the top of
the reservoir. How do I correct the issue?

the plug gap changes to .040 from .060 with stock and platinum plugs. What are the bet plugs to use in my 6.0 liter engine?

very hard to steer and just about no breaks at all, hydra boost has a small leak at joint of casting between the 2 halves. hope you can help

I have a 2001 GMC 1500 4.8l and I am getting 11-12 mpg's on the highway, could this be an 02 sensor? My air filter is new, plugs, wires, and fuel filter are also new.