I brought a part but It doesn't seem like right part. It's long, with two terminals on one endend, and a threaded end with plunger. The same switch is on the front of my break shaft not the back, that's why I think I might have the wrong part.

We replaced wires and plugs already. It showed no warning b4 it died. Just didn't start back up one day.

Checked fuse, i am getting continuity up through the push button on turn signal lever, replaced small black box under dash, left of steering colmn. i have great vacuum to throttle actuator. please help!

it just turns over and over and will not start what could have happened to cause this?

I foud a 3 wire black sleeved cablr coming from the cruise/wiper/turn sign. switch on the column that has a receptacle i dont reconize,I had a s15 before that I replaced the column in from a truck with cruise but mine didn't have it so I didn't worry about it.This truck is original & for some reason it's been disconnected,does anyone know where this wire is supposed to plug in? I am assuming this is why my cruise is not working, any help would be greatly appreciated..........thanx

it acts if it is flooding can this also be the fuel pump? I was thinking throttle position sensor but not sure. It wont idle after it warms up. hold throttle to floor to restart smell gas. The serging is at any speed including highway.

my 1988 S15 jimmy 2.8 liter will not crank on the first turn of the key i have to turn it at least 10-15 times to actually get it started and when i do get it cranked it shuts off and it shakes the whole time its running when first cranked. once it does get cranked and i put it in gear it will shut off and back fire through the throttle body. i have replaced my wires,spark plugs, distributer cap and rotor button, along with my fuel and air filter. does anyone have any idea what could possibley be wrong with my S15 jimmy?

turn off we had to pull the coil wire and then unplug the battery what could the problem be?

the truck will idle but when I press on the gas pedal it falls on its face. can't get above 25mph on any hill and sounds like it is running on 2 cylinders. the engine is 4.3 V6, and I just changed the fuel filter. No check engine light either.

My jimmy is stuck in 4 wheel drive. How can i fix this problem

I just replaced my 1987 2.8v6 engine, transmission and underhood wireharness with a 1990 4.3v6. I bought a new computer for the 1990, a new map sensor and of course the 4.3 was brought to the machine shop for the heads and block. My question is I put an MSD distributor on it with coil to get better performance and I am having high idle, busting out on the top end and some times it loads up at the longer red lights. I have not replaced the old throttle body and was wondering if it was the problem?

i have installed new battery & alternator on 1986 Jimmy,and my amp meter is 11 or 12. and should be 14. Can this be a cable problem

gas goes into the throttle body but doesnt come out. i have cleaned it and changed the injectors and it still does it. it happens about 1 out of 5 times i try to start it.

one of the three main wires that run off the starter that power my car broke on my 1985 gmc jimmy s15. I fixed the wire now my truck will only turn over I cant get it to start.