135
questions

and it still runs rough and the engine light is on

When changing the fuses they kept popping and dying. Is this from the Solenoid and what is the basic cost of fixing.

my serpentine belt broke and i ran the engine with it off to baton rouge Louisiana from walker Louisiana and before i got to my mechanic shop it lost power and died i checked my oil its still black i had no water in my radiator it was dry what do you think I've done to it?

i like a diagram of it

lights flicker when u use in buttons like the locks or windows does this van have a voltage regulator

gasket set, new wires and plugs, and erg my light has stayed off great except when I get around 30-40 mph it still feels like its missing but when I give it gas it runs smooth and and stopps missing could it be fuel problem? Transmission is smooth and shift into all gears properly but in town around 30-40 miles it feels like missing

my mechanic installed new wires, plugs engine light came back on annd still missed at that speed he then put it on diagnostic and a smoke test he then installed upper intake gasket set , EGR Control Solenoid I drove it around for about 10 miles it still miss at 30-40mph my mechanic said to always drive with overdrive off in town it will drive smoother and then the engine light came on after he said that WHAT ELSE COULD IT BE ?

shaft position sensor it went about 5 miles light came back on he then installed new plugs and wires it went approx 20 miles engine light came on and still missing at that speed he then did another reading and smoke test and did upper intake gasket set , EGR controil solenoid still mising around 30-35mph he said use overdrive off in town and that should not let it miss at that speeds I still have a miss but it does great at all other speeds he said fords are good for this and riuning transmissions if left to drive in overdrive at all times. WHATS NEXT I have diven about 30 miles engine light is out but still missing at 30-35mph

MECHANIC REPLACE CAMSHAFT POSITION SENSOR AFTER ABOUT 5 MILES THE LIGHT CAME ON AGAIN NOT ALL THE TIME MY VAN STARTS TO SPUDDER AT AROUND 30 MILES AN HOUR I GIVE IT GAS AND IT DRIVES GOOD ALSO MY VAN WHEN SITTING AND RUNNING IT ACT LIKE IT WANTED TO DIE A COUPLE OF TIMES

My outside temp readings are incorrect by about 50 degrees

The coolant is a tad low, just barely. Shouldn't cause any problems like that. And the rear heater seems to be working fine. There is a rear heater control for the back passengers. Idunno...

Cmoke about 50% of the starts. No engine warnings, or codes.
Ford dealership maintained per schedule. Just had new ball joint replaced along with a cross member reacall replacement. No issues until after the last replacement service. No change in mileage per gal. About 27 hwy, 18 City. Car otherwise in excelent mechanical and cosmetic condition. Garaged if not on highway.

I have a clunking noise from the front end on rough roads when hiting bumps. It goes away if I ride the beakes when I check the calipers they are loose and make noise when you hit the tire . Is there a way to fix this. Also new brakes and all bolts are tight

how much to do a tranny replacement in a Ford Windstar 2002? approx is fine. especially if you have had to have one replaced in this or a similar year winstar.
thanks

Tank is full. What could it be?