1990 Ford Thunderbird SC Questions

All 1990 Ford Thunderbird SC Questions

Ask a Question
had just changed the valve cover gasket and replace the throttle with a crown victoria throttle
gas it wants to stop but wants to go when I let off. also I have to hold both break and gas pedals down for it to stop
problems when I push the gas it wants to stop but when I let off it wants to go can anyone help
90 super coupe 115XXX miles. Car just likes to crank And crank.has fuel pressure and after a few second to a few minutes depending on the day of cranking it will finally start. Any idea where to begin will help
AND ANY OTHER PARTS THAT ARE NOT RE-USEABLE AND MUST BE REPLACED TO DO THE VALVE COVER GASKETS
this started Sunday, i made it home, but not without having to put the car in neutral at every light ,tap the gas to bring the idle down, but when it got down to what is the new normal 2-3k idle there is a nasty hummi...
was told that it was the inter cooler that needs to be sealed correctly or it wont start is this true ive had the car for 2 years fixing it a bit at a time on my own but stuck on this last bit please help
problem started about a week ago and is consistent. Car has 144000 miles.
restart it ,it runs rough for awhile , and then smooths out afer I get moving,also i notest that if i run the ac unit it doesnt start back up rough,what can be the proublem, new o2 sensors airflow sensor i re place i...
but the brake,s are still hard and the light,s are still on, what do you think it may be, i never work on anti lock brake,s, just boat,s, been doing that for 22 year,s. back when i was very young i was a line mechanic...
the two light,s are on and the brake peadal is stiff and it,s like I have very little or no brake,s i have checked the fuse,s i think it,s 3 in all, there all good, how do i check to see what is wrong?
i have changed coil pack camplacment sencor crank sencor wat else could it be
car has been sitting for about a year and a half brought it home put gas in it started up warmed it up shut it off and tried to restart it about 5 min later car has not run since .