39
questions

It's a beautiful truck only used for towing horses in a trailer

auto transmission seems to slip from overdrive to drive causing rpm's to get to high and slips in just drive more often the meter reading on the selenoids was the same in the first 2 [about20.2 approx. on all]it has new filter and fluid and did not smell burnt and also not to much shavings or trash in filter not at magnet in pan

i have two tanks and two low pressure fuel pumps and a high pressure fuel pump and none of them are working change the relay and fuel filter still no gas i can,t see all three pumps burning out at the same time in both tanks also checked fuse under dash is there another fuse some where else

7,3 diesel

When I start it it knocks when I drive it knocks. Thinking a sloppy wrist pin or something along them lines any ideas??????

Question Asked: Brakes on a 1990 F-350 4x4 7.3 diesel. I have replaced the whole system..
January 31, 2015, 03:19 PM
Meaning the back drums and front calibers, I also have replaced the booster, master cylinder, & the ABS block on the frame for the back brakes only. I used the Haynes auto manual & procedures to bleed the system properly as well as installation. I have got a good petal to start with but it will leak down if I hold it down for a short period of time so I'm totally confused on what is going on here any suggestions will be greatly appreciate.

Meaning the back drums and front calibers, I also have replaced the booster, master cylinder, & the ABS block on the frame for the back brakes only. I used the Haynes auto manual & procedures to bleed the system properly as well as installation. I have got a good petal to start with but it will leak down if I hold it down for a short period of time so I'm totally confused on what is going on here any suggestions will be greatly appreciate.

5 speed manual transmission fluid capacity and type

truck is "88" never a problem like this, has fuel, new filter,just cranks an cranks till batterys get low,no computer, hope you can help,its been sittong for about two weeks now!thanks

I Have pulled both filters the in tank pump is pumping revs up strong and then dies idles ok but then dies in a minute I have to pump the gas peddle to get it going it does backfire a bit on starting but runs not bad, but when it decides to quit there is no coaxing it, it just quits. the oil pressure is great. please any direction.

Truck has a gerling brake system,and it has a thumping noise in the brake pedal and the pedal shifts back and forth a little each time you hear the noise.it only does it when the parking brake is released,the noise seems to be traveling down the pressure hose from the pump.


any info on this would be helpful Thanks