Close
200
questions

Got a PO353, PO356,PO358 after changing all Spark Plugs and all Coil on Plugs, also getting misfire when gas pedal is released
Starts up fine
Checked connects look okay
Checked spark plugs look okay
Checked wiring

Changed Coils all 8 and spark plugs
Didnt have this problem before
Also getting a misfire

Sometimes when I try to start the engine it sounds like spinning gears making a high pitched grinding noise, like the starter isn't engaging or something. After I try it a couple times it will start and seem fine til it happens again. Like I said it is random as far as I can tell and fairly intermittent.

3 months ago we did one side head gasket becouse water inside oil but now i have oil inside the water reservor 1999 ford expedition 4x4 5.4l

I had the manifold and manifold gasket replaced along with the thermostat and since the front only blows cold air when heat is on but the back blows hot now I am smelling antifreeze also since the repair my truck seems to act like its going to die out when I start it and it bogs down when im driving on the highway what could be the issue

1999 170,000 miles am told the problem is plugs and wires, but they were changed 30 months and 23000 miles ago

had the plugs and wires replaced 30 months ago and they say I need them again, does that sound right?

PROBLEM WITH MY 1999 FORD EXPEDITION

starts when its above 25 degrees

but no water in oil i ckecked and have a code po113

where is it and is it hard to fix

The cost of repair is too high for me I would like to replace the engine with either a used salvage yard one or rebuilt one or maybe a new one. What is the cost of these choices?

The add ons are what puts the price of repair out of reach for me. I need head gaskets only. The other stuff is good and all that for those that can afford it.

I think it is the controller for the front heater core how do I access

I have had this problem for some time now. We have replace the vacum hose twice and still does the same thing. Where else should i look to fix this problem?