Close

1999 Ford Expedition Questions

Get answers to questions about your 1999 Ford Expedition at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
204
questions

already replaced front brakes,mastercylinder ,well bled the breaks. problem still exists

Whenever I start off in the morning, I get a slight grinding noise from the drivers side front. Only lasts around a hundred feet, but the 4x4 light on the instrument cluster starts flashing. It does this until I shut the vehicle off. Then, if I imediately restart and start driving again, I get no grind and the light stays off.

I backed over my sons tricycle tonight and afterwards when I drive forward or reverse there's a screeching metal grinding sound. It almost sounds like the brakes locked up or something is stuck but brakes look fine. A hose came lose but it didn't seem to go anywhere.. I put it back on.. Gassed it forward and back and it seemed to loosen up but went right back to doing the same thing.

If you get into the pedal, it jerks and pops. Also, it feels like something catches on the right side and it pulls that way until it releases abruptly with a jerk. I am willing to go 2 wheel drive but just need some advice.

Changed stableliser n truck won't take grease, still makes loud noise, when turning, hitting a bump

I need to replace the engine in my 99 Expedition 5.4, what years/models are interchangeable?

I took the 4.6 out of my expedition and put a 4.6 out of a mercury cougar and it will turn over but will not run

Yesterday leaving my house started the truck put in drive and when I pushed the gas it drove but rpm was high and it was not catching speed. Checked transmission fluid. Was low so added fluid. Tried to drive again did the same thing. Had someone come pull us home and noticed transmission fluid was leaking.

Has been twice already each time using different brands, the guide seems to just break off and fall into oil pan, bolts are still on engine

slipping and grabing,during this sensation there is a increase in the R.P.M. and also the check engine light comes on