17
questions

The engine stumbles maybe every 50 miles. I have replaced plugs, wires and a fuel pump, it has about 90,000 miles on it. I had a shop put in a remote alarm system for me about three years ago, they must have disconnected where you read the codes (it does not work). Any help would be useful.

I have changed the thermostat,heater hoses are hot and in good condition. I have a blend door switch and and a selector switch coming in the mail and the door actuators seem to be working fine. No codes on my scanner. Any suggestions on what I'm missing?

Thank you
Barry Brown

Two different car parts places scanned my van and received no codes from my system--they thought loose wires under dash (I don't believe it) or a blown fuse for the diagnostic system--I don't know what fuse that would be or how it would be listed

need directions how to get the dash out

charge slowly drain when parked

AFTER DRIVING MY 2000 E150 , I SMELL GAS , CANT FIND THE SMELL,DOES IT HAVE A charcoal canister?

brake pedal gradually goes to floorboard;no loss of brakefluid;what to check next?

ho much to replace oil filter housing on a 2000 e150 van 5.4 engine

Whta kind of collent is the right one. Green or orange?

no heat coming out, only little warm on the floor after the car runs for a while

In order to stop the anti-lock model from running I had to pull the fuse even though the key was turned off

how do I remove headlight

electricwindowondriverside







changed brakes on front, driver side is great but passenger side keeps rubbing ! how do i correct this ?