76
questions

I do this change I need specs in torche and whatever else I need to know about changing them

It had a knocking noise and I'm trying to change out bearings but don't know torches specs or how to do this.

Replaced timing chain, cam sensor, crank sensor. Still no change. Out of options.

the car will start and run but after a few men it will run rough and cut out until it dies,it will start back up but runs rough and dies if you push the gas it dies but if it is left alone for a few hours it will start and run fine for a few min then it repeats the cycle. I have put new fans new raideator new relays for fan and new 50 amp fuse

I am trying to figure out the general cost of repair to have the transmission cooling lines replaced, "assuming that's what the problem is" or any other information you can tell me of what the problem could be. It started out a very slow leak from the front driver side of the car below the radiator so I didn't worry about it too much but kept an eye on the level of the trasmission fluid to make sure it didn't get too low. Now it is leaking a lot faster and I cannot put this off any longer.

I am trying to figure out the general cost of repair to have the transmission cooling lines replaced, "assuming that's what the problem is" or any other information you can tell me of what the problem could be. It started out a very slow leak from the front driver side of the car below the radiator so I didn't worry about it too much but kept an eye on the level of the trasmission fluid to make sure it didn't get too low. Now it is leaking a lot faster and I cannot put this off any longer.

I've been having this popping or clunking noise when going over bumps or stoping. I was told rack and pinion. I replaced that, and its still doing it. I hope I Wasn't told the wrong thing. So frustrated. What about the sway arm bushings. Plz help.

If I wait until the next day, it might start. A friend said that it's either the crankshaft sensor or the modulator. What do you think

shows code 4th gear ratio incorrect never showed signal of going out

Here's the deal...I have had the battery and alternator checked and both are fine. The problem is as I'm driving sometimes the car loses power as if the battery is being drained. The dash lights flicker, the radio goes off, and if the air is on, it doesn't blow as hard. If you turn the car off at that point, it will not start back. After jumping car off it's fine again until this happens again. If you continue to drive it eventually the dash lights go out, the radio comes back on and the air blows at full strength. Also, after turning engine off, it will crank up as if nothing is wrong. It's driving me crazy....HELP please!!!

Here's the deal...I have had the battery and alternator checked and both are fine. The problem is as I'm driving sometimes the car loses power as if the battery is being drained. The dash lights flicker, the radio goes off, and if the air is on, it doesn't blow as hard. If you turn the car off at that point, it will not start back. After jumping car off it's fine again until this happens again. If you continue to drive it eventually the dash lights go out, the radio comes back on and the air blows at full strength. Also, after turning engine off, it will crank up as if nothing is wrong. It's driving me crazy....HELP please!!!