58
questions

This start happening after I had my oil changed. I also noticed a decrease in mileage.

ive change the thermostat the radiator cap flushed the heater core and the temp gauge shows normal operating temo

I shot starting fluid in the breather and it starts and runs fine any ideas?

I have changed the transmission computer and the shift cylonoid*(SP?) it just does it sometimes although it is happening more often

I have changed the transmission computer and the shift cylonoid*(SP?) it just does it sometimes although it is happening more often

I have changed the transmission computer and the shift cylonoid*(SP?) it just does it sometimes although it is happening more often

I have changed the transmission computer and the shift cylonoid*(SP?) it just does it sometimes although it is happening more often

I have changed the transmission computer and the shift cylonoid*(SP?) it just does it sometimes although it is happening more often

I have changed the transmission computer and the shift cylonoid*(SP?) it just does it sometimes although it is happening more often

I have changed the transmission computer and the shift cylonoid*(SP?) it just does it sometimes although it is happening more often

I have changed the transmission computer and the shift cylonoid*(SP?) it just does it sometimes although it is happening more often

I have changed the transmission computer and the shift cylonoid*(SP?) it just does it sometimes although it is happening more often

I have changed the transmission computer and the shift cylonoid*(SP?) it just does it sometimes although it is happening more often

I have changed the transmission computer and the shift cylonoid*(SP?) it just does it sometimes although it is happening more often

I have changed the transmission computer and the shift cylonoid*(SP?) it just does it sometimes although it is happening more often