Started for about 20 minutes then died again it won't start again the odometer blinks 9 or 10 then says no bus help I am at a loss

Engine cuts out when overdrive is engaged on 2002 Dodge Ram 3500 van. Why?

No low or medium speed function.

It thinks it's in reverse. I can however shift it into park once the engine is off but when I go to start it, it still thinks its in reverse and I have to shift into neutral to actual start the can. Any help would be great

2002 dodge ram 3500 cummins automatic.truck wont start unless I jiggle the shifter on the column. replaced neutral safety switch didn't help. about 50% of the time it starts just fine. is there some kind of safety switch in the column? anyone have any ideas?

It goes away when I decelerate or spped up but then comes back again. IS this something minor or do I need to look at it right away

The shop says this was incidental, not related to computer. Mechanic hooked up code checker under dash and showed me that there was no ABS code.

There are no major leaks anywhere and not smoking yet I am 2qts low after 1 week.Can't fig out where its going.It has 87,000 miles on 5.2 318. Van runs excellent other than that.

crank sensor and pick up.also has had recent tune up.

Can't seem to change the date in repair history under MyCar.

I go to MyCar and click on the service name in the repair history for the repair to edit.

Click on the edit button, whitch brings me to the edit screen.

However it will not permit me to click on the calender to select a date or type in a date.

What am I doing wrong???

After backing up in reverse, when I shift to "Drive" the engine dies immediately. Cranks up again okay and then goes forward okay. This problems repeats each time I go in reverse and then shift to Drive. Repair shop cannot find anything wrong.

Always started a first rotation. One day, rotated but would not start. Towed to shop. soon as offloaded from wrecker, started right away. Started at first rotation every time since. Don't want to get out in the boonies and not start. What happened?

Took off with my truck one morning, seemed to drive fine. After about 10 minutes I tried to accelerate. Then it backfired, stalled and wouldn't start. Replaced plugs, wires, cap and rotor. Truck fired right up, ran for 20 minutes, backfired, stalled and will not start again.

my bus stopped on the highway will not fire though engine rolls Changed the crank sensor and it fired first hand and ran 30 minutes stopped. Put another crank sensor did the same thing. Whats the matter