Symptoms of a bad wheel bearing.

Driver side tire starting to shudder .
I don't know if it's a ball joint something else.

Any 1 here has dealt w/ this b4

I've been reading other post w/ similar problems Nd ever1 points to PCM box.

has any1 bought a refurbished pcm Nd wat luck have they?

How to solve motor revving up and down too much when AC compressor turns on. 3.9 L. RPMs are really running High

I bought a 2002 Dodge Ram 1500 conversion van recently. It came with only one key, and on the key ring is a little white square that says Chrysler on it. On the dashboard, is a white dot that you are supposed to hold the square up to and it disables the anti-theft device which otherwise won't let you start the vehicle. There is no clicker to lock/unlock the doors or disable the alarm, just a key and that square white thing. My manual seems to imply that maybe there was a clicker, and it says nothing about this white square thing. I'm afraid of what will happen if I lose it and want to learn how to get another one and also if the vehicle once came with a clicker to unlock the doors, etc. Can anyone with experience with this vehicle speak to this and provide me with some guidance? Thanks in advance!

Towed to Mechanic, who now is talking about the computer in the vehicle.
I had the radiator open adding coolant.

tried a new master control but no change. the lights on the switches light up with the ignition. on rare occasions the windows will work but very rare. seems as if something is not sending the signal to run. can you help please what do i ck next. Fuse seem fine.

My tyranny will not go into park so I can get key out will start in neutral and change to other gears except park pulled linkage off shift into park to get key out put linkage back on still won't go into park ? Any advice will be great appreciated

Is there a circuit that could be shorting, causing the PCMs to fail that commonly occurs on these models? Several times people have mentioned the O2 sensor circuit; is that a good place to look?

also has had two tune ups ( second one was done without asking ) new o2 sensor. brand new $300 PCM now the damn mechanics cannot get it to start!

then where the mileage shows I am getting No Bus where the numbers are. If I let it cool down it will start until I am driving for awhile then it shuts down again. What does no bus mean?

we changed the crankshaft position sensor and the cam shaft postion sensor the codestill reads p0320

dash lights go off.

It started when I ran low on gas. It keeps shutting down after running a few minutes unless I keep my foot on gas pedal.

MIL on / computer is new ( rebuilt )

i have put a fuel pump, a water pump, a crank shaft sensor, checked all the fuses, made sure it has gas , put a new distribtor on it ....don't no what else to do please help with info asap....thanks