133
questions

stopped running on highway put in new battery. started drove a few miles ran hot and out of oil.

2005 dodge caravan, 3.3 liter v6 with 150,000 miles. It can be shifted but you can't see the gear and it won't move until the gauges light up. The alternator and serpentine belt were replaced 1-27-12 at 106,000 miles. The problem occurs almost every time it is started.

start up van - headlamps - windows - wipers - horn - blower motor - key powered acc. outlet does not work. Battery powered acc. outlet does work. Air bag light on, no seat belt light on even when seat belt is hooked

The radiator overheats when idling or in heavy traffic. I've checked the fuse (OK) and the fans turn manually, so the fan motors are not seized.

Radiator fans not working. Fuse checks out alright. Fans spin manually, motors not seized.

No shifting issues and I changed the fluid & filter. This transmission was replaced in 2009. It has 31,000 miles on this transmission. I need it to pass emissions test and don't know what to try next.

while being stuck in traffic and at a stand still my van all of a sudden starting a loud humming and vibration sound. at first I thought something happened to the air conditioner so I turned it off and turned of the ignition. I waited a few minutes and started my van up with out the a/c running, after idling for a little bit the loud hum and vibration started again. well by that time traffic started moving so I started driving and after a few minutes the hum and vibration stopped until I was at an idle again then it started again when the radiator fans kicked on, well traffic started moving again and after a few minutes of driving it stopped making that vibration until the next stop and idle.

Whenever I turn the air conditioning on in my 2005 Dodge Grand Caravan, there is a noticeable and pretty loud chirping sound that stays on as long as the air conditioning is on. What could it be and how can I fix it?

The front blowers in my vehicle are not working, but the rear blowers work great. This happened about a month ago and I replaced the relay behind the glove compartment. The air/blowers worked fine for the last month and randomly stopped working again today. Any ideas on what could cause a relay to stop working again? Is it possible that the hoses/filter are just dirty and need to be cleaned out/replaced? I'm ordering a new relay and an air filter right now. What could be going on? I would really like to try to get it done myself.

my lift gate in the back of the van will not unlock any more, is there a fuse that controls it or is it a modual and where can I find it on the van?

I have red liquid - the same color as the power steering fluid - leaking from what appears to be a small radiator underneath the passenger side of my 2005 Grand Caravan. I'd like to know if this liquid is indeed radiator fluid (that is trickling down along hoses from my leaking power steering fluid assembly to this tiny undercarriage radiator) or some other fluid - like transmission fluid or coolant. I don't suspect it's coolant and the coolant levels are staying good. It could be transmission fluid though. I know for certain that I appear to have a power steering fluid leak from the hose that attaches to the power steering fluid reservoir. But, at minus 50 degrees celsius, I'm going to wait to address it. Thanks in advance.

It currently has 202,000 miles and I have had no engine or transmission problems. No leaks. I keep it maintained with regular oil changes, not the high mileage oil,just the regular oil. I have not replaced the serpentine belt but I do not see any cracks in it. Is this vehicle as is still reliable to drive on a 1500 mile trip without worry it is going to break down?

If I accelerate very slowly it usually doesn't make the sound.