13
questions

I replaced crank sensor, cam sensor, coil pack, checked timing chain ( good ). Still no spark or fuel. Found a white fusible link that was melted, there is the white one, and an orange one, that tie into a 10 gauge wire. I cannot find the problem, currently checking relays. Can someone give the info that I need, been working on it for two weeks to no prevail.

I can shift just fine thru all gears and then suddenly it will slip and wind out into neutral and then downshifts into second . Wont go back into drive forcing to drive in lower gear and sucks up all my gas other wise it drives nicely I have aligned front end and struts also changed high speed sensor was told it might me another sensor or possible linkage . also speedometer and gas gage work intermittently . I am getting very poor mileage due to driving in lower gear

I will turn the heat on to allow warm are to flow through the ducts. At some point in time there will be a "switching" noise and it will automatically change from going through the ducts to going to the defrost vents while the button on the controls will be on the for the ducts only. Again some time will pass and the "switching noise" will go from the defrost vents back to the origional position through the ducts. I have replaced the heating/cooling controls twice with the same results.

If I play blower motor controls for about a mile (rapidly changing from high to low then high then low) I can get it back to flowing from the ducts and not the defrost vents.

Again when I press the button for heat to travel through the Ducts at some point the heat will automaticlly change from the ducts to the defrost vents without the defrost button not being touched.

Thanks

vehicle will not start at times and I have been told tghis is the problem

This noise just started today. I hear a clicking noise in the vicinity of the alternator, near the power steering pump. I have had an ongoing power steering leak for over a year. I do keep the resevoir filled as needed; checked weekly or more often. What is the estimated cost of repair for this? I hate it when garages overcharge a woman for repairs.

Where is the crank sensor and how do I replace it?

SHIFTS SOMETIMES AND WONT OTHER TIMES VERY ERRATIC WHEN IT WORKS IT WORKS WELL.CHANGED SPEED CONTROL SENSORS. AND TRANSMISSION CONTROL MODULE. I ORDERED TRANSAXLE AND SHIFT RELAYS.MY CHILTONS MANUAL DOES NOT IDENTIFY THE LOCATION OF THESE RELAYS.FRUSTRATED!!!

change my spark plug in a 1992 Dodge grand caravean 3.0 L

Loosing power at highway speed. chug and jerking also.

my rear wiper stopped working and everytime i replace the fuse it pops as soon as i put it in

Just did the the rear brakes and put a new brake line on and now the abs light and brake light both come on and the brakes are very hard, they work but not very well. What could cause this to happen?

i have a 1992 dodge grand caravan and i need to know the size tires that go on it. it has 20570r14 on it but i need to know if they are the right ones or can i put another size tire on it?

My speedometer and gas hands do not move in my van..the light do not light up either for those things. Someone said it could be a fuse I did check the fuse box next to the steering wheel but nothing seems blown is there another fuse box that may have the problem if so where is this located?? Thank you