54
questions

Then my service stability track light came on as well

I had deferrencial fluid checked ND it was fine.a no met flakes. Terrible roar at times, not all the time in the back.

My transmission is in Celsius so about 110 and we back off and slow speed and really watch rpms etc. We r not towing anything and below but 110 celcius is about 240 F I think. I am not towing no large hills and mostly freeway driving. Outside temp is middle 80 f and high humidity. When I turn off air conditioner it cools down to 92 but will get up again. I have flushed transmission and checked cooler.they say it is working fine.

prices on fixing the stabilitrak system on chevy suburban

the light in odometer is out and found a repair rebuild kit #131553250041 and wanted to know if i could repair this myself

even after I changed the brake light switch 3 times. could there be a short or blown fuse somewhere?

Got a fault code for that.

the oil gauge on the dash has stopped working since this leak could it be a fuse? if so where is it located?

I just had the front axle replaced. Right after it was replaced I switched the vehicle from 2WD to auto and a rumbling noise came from the front of the vehicle when pushing on the gas and slowing down. Considering it did not do this before the axle was replaced could the replacement have caused the issue because now they are telling me I need to replace the front end differential?

My cruise control light will turn off/on but will not engage. I keep hearing it's tied to the 3rd brake light. I also heard that this if you replace the brake light switch, it will solve the problem. Any advice would be appreciated.

belt tensioner and a/c belt have been replaced, a/c tensioner has been replace twice first time it broke off second time it just rattles at 1500-2000 rpms but only when the a/c is on

Was a class action ever filed? Have been dealing with oil consumption for years, deflector installed minor impact but still using oil. Recent problem with engine light and service stabiltrak error message. Told tests yield no compression in cylinder #7. Advised proper fix for long term is replace engien and control box. Seems to me like GM should be paying. 140K miles now purchased new from dealer.