Close

2002 Chevrolet Silverado 1500 Questions

Get answers to questions about your 2002 Chevrolet Silverado 1500 at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
150
questions

My clutch goes all the way to the floor

Clutch goes all the way to the floor

REPLACED MY BATTERY. O2 SENSOR HEATER AND EVAP MONITOR SHOW NOT READY. WILL NOT PASS EMISSION TEST FOR STATE INSPECTION.

I checked everything but fuel pressure

will not shift out of two wheel high. i have heard of a module or some kind of solenoid to replace first. what is your suggestion.

I have a 02 silverado with vin T, I need to find out what year motors can I use to replace mine with little to no adjustments.

I found a 1999 5.3 and want to put it in my 2002 silverado 1500 but I was told I will probably have to switch a bunch of stuff, so my question is will the 1999 5.3 go right in my 2002 without changing any connectors or wiring harness or will go right in? Thanks

Break line seems to be leaking from somewhere. No breaks!

It was running perfectly fine then I changed the radiator coolant and now it runs hot out of nowhere, I've checked to see if it was the thermostat sticking but it's not that, should I bye a new water pump?

no mater which position the selector switch is in.

just started doing this the last few days since the weather warmend up

Truck sputtering while going up any grade hill but on level ground runs fine. I've changed coils, wires, plugs, knock sensors, o2 sensors, fuel pump, fuel filters. Any idea why it does this it's driving me crazy not figuring it out. Plz help!

I,m at a stand still. i repaired a 02 silverado for a friend and after 2 days it stopped running while he was driving it. He says it just lost power and shut off. I did plugs ,wires , repaired valve cover gaskets, pcv, oil change . Today2/28/16 i replaced fuel filter-no start, checked coils-all had spark, checked fuel rail-pressure good, took exhaust off thinking back pressure due to plugged cats or muffler-no start, tried starting fluid still nothing. It just cranks with no signs of starting. I got an obd reader and his port doesnt work checked all the fuses and they were good so im stuck . I know cam/crank sensors could be bad , is there a way to check these with an ohm meter as their both 56.$ a piece. im trying to get OBD port to work in the mean time .

Can't find egr on 2002 4.8 v8, is not where the manual shows it to be and I can't locate