Close

1994 Chevrolet S10 Blazer Questions

Get answers to questions about your 1994 Chevrolet S10 Blazer at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
49
questions

need to know location of all freeze plugs on my 1994 jimmy s10 2 wheel dr 4.3 v6 thanks

Sometimes it'll go off then I might hit a bump and it will come back on or hit a bump and I'll go off

to start everything worked great..the only problem was the 4x4 switch..i have to pull out the tccm fuse & unhook the battery for a few and hook up bat & put fuse back in and then hit the switch & and it works

periodically, my dash would shut off and start working again until it finally died for good. i tore it apart and found three blown capacitors. two of them are 47 uF 50V, and 473K 400V, but the one i cant find got goo all over it and peeled up the plastic... the only numbers i got off of it are (M) 105^o C/ 34/N(5)... can anybody help me?

and a new raditor after running hot andf the old one burst. what could be wrong? Now won't start at all and a friend said that the head gasket was blown.

My blazer started bogging out on my and eventually would die and would not start back up until it cooled down. I changed the fuel pump and wiring, it ran good for 3 or 4 days then began to bog out out again and eventually it would idle very rough and die when I would give it gas. I've changed all sensors, plugs, cap, wires, and still no change. I've pulled all my hair out trying to figure this out please help.

I've change everything I can think of on this blazer and it still won't run. It barely idles and bogs really bad when I put gas to it. All sensors have been changed. Cap, plugs, wires have been changed. All plugs are now fouled after trying to start it. No codes come up, and check engine light does not come on. All fluid have been changed as well.

how do I engage the 4 wheel high on a 1994 Chevrolet s10 Blazer am I supposed to be driving while doing this or am I supposed to stop and put it in neutral?

when I'm in neutral I hit the 4 wheel low and I can hear it engage.

The compressor clutch wont engage. When I went to try to manually engage the thing, I couldn't find any relays for it. If anyone could tell me where it might be, or how to manually engage it without one, that would be awesome.