1990 Chevrolet S10 Blazer Questions

All 1990 Chevrolet S10 Blazer Questions

Ask a Question
What kind of oil should I use to change the transfer case fluid
Sometimes it'll stall without putting it in drive. I can pull each plug wire off one at a time and it stalls,which makes me think each plug is firing. I recently replaced the coil. I cleaned the portal for the IAC and...
Sometimes it'll stall without putting it in drive. I can pull each plug wire off one at a time and it stalls,which makes me think each plug is firing. I recently replaced the coil. I cleaned the portal for the IAC and...
fuel comes on changed fuel filter put on new coil does not appear to have spark or fuel.
Gas is good and clean and the two injectors work and fuel comes out when tring to start. All fuses good. It was running fine, parked it and tried to start it two days later. Would not start. I used started fluid, no c...
I have a 1989 Chevy S10 blazer. When I turn on the A/C, no air blows out the passenger side vent and the right vent in the middle of the dash. Waht is causing this? Thanks.
will it start out of time
i have a 4.3 liter,high idle when it first starts then after it calms down it idles rough just wonder what options could cause this
i hit a drain pipe with the front passenger side wheele and now it sets back toward the door and its not centered in the wheele well could it be a bent tie rod? or is it something else?
could a bad coolant temp sensor, egr or map sensor cause lack of power, slow pickup of speed when I slowing let off on the pedal. I get a pop through the TBI when I gun it and want to stall. and also been wanting to ...
actually an 89 but that was to old for the selection list but anyway i just changed the front seal due to a fluid leak all went as well as that could but now it doesn't shift into overdrive with any regularity please ...
alway the same,popping through carburetor, lack of power on acceleration, slowly pickup speed if I let go of accelerator pedal out slowly. I get poor mpg about 10miles per gallon. are 4.3 bad on gas. thanks