Close

2010 Chevrolet Express 2500 Questions

Get answers to questions about your 2010 Chevrolet Express 2500 at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
4
questions

The driver side has no spark but the passenger side everything work good I changed all the spark plugs coils and still the same problem anyone know what's wrong or what I can try

I drove it 20 miles since with no problem indicating any problems could it be that it just lost power to the transmissiom?

The dealer's service center recommended and changed our differential fluid for $95 and indicated that it should be serviced every 30,000 miles. I can't find anywhere where it says how ofter it should be changed.

I use my van everyday for work with no issues. However this morning it snowed and I went out to let it warm-up.
When I went down the road it was fine for about 3 miles when all of a sudden it lost power. The display read "Loss of engine power" and an engine icon showed up
on the dash. Tho only pre-cursor (if this is one) would be that for months now as I backed out of the driveway and then put it in drive and stepped on the gas - the engine would hesitate and on rare occasions stall. This would also occur in parking lots where the engine had been warm already. Would anyone have any ideas what this new 'loss of power' problem might be caused by ? I understand there are coils around the spark plugs that cost $100. each (OUCH !)I'm just hoping this is something reasonable. Thank you.