13
questions

already changed fuel pump, fuelpump relays, oil pressure switch, crank sensor, coil, icm

the car will not continue to start consecutively and stay running and now the tachometer needle is not working properly when started, prior the tachometer was working fine also the car runs good when started it just won't keep running when driving what is problem I need answers please.

would it be easier to replace the rear axles and the differential using a used rear end from a different chevrolet 1500 van with a 5.7L engine

After replacing crank sensor,fuel filter, fuel pump,spark plugs,plug wires,cap and rotor the po303 code comes back on after a while. I plan on taking a little trip in it,will I break down or cause a bigger problem. The van seems to run fine. Just runs a little ruff for about a minute then seems fine.

whats the fuel pressure for a 96 chevy van express 1500?

Its only spitting out 15lbs.

Engine will quit at various speeds slow to highway. does not run rough. Will start right up after quiting.
Engine will quit at initial start of day and various times thereafter. Sometimes it is fine and will not quit during a day. Run diagnostic and no codes came up.
I am original owner. 85k miles. Van is used infrequently. Sometimes may go 2 weeks between usage and starting.

I evacuated the system, vacuum pumped it for 45 min replace the orfice tube and its still doing the same thing as before.At times it blows cold air in all the vents.What do you think the problem is.The pressure is reading 40, so it is full of freon.Also the other vents are blowing cool air but but not cold and if I turn it to heat it instantly gets hot air.

wind blew door open and it wouldn't close properly. Macco repaired for $150. Two weeks later door wouldn't lock shut. They want an additional $500 to repair. Said they did the quick fix first and now have to do heavy-duty repairs because car is 20 years old. I think $650 to fix a door hinge seems way too high. Macco is a block away that's why I went there.

The van jumps whenever I shift it into gear but runs good after that so I don't think its the transmission or I'm not sure if its the timing that's off.

I have a 96 chevy express. yesterday while idleing, it stalled and would not start. a few minutes later it would start it ran for about 2 miles then puttered out. would not start again, waited a few then it starts but only gets me about .25 miles.
I made it home after many stalls... any thoughts? Please.

recently the van has experienced a total loss of power when accelerating. diagnostic codes p1133 and p1153 and p0151 were found. i replaced both upstream o2 sensors and the maf sensor. no good. found a vacuum leak in the upper plenum and regasketed that. nada. van hard start now and as soon as you touch the accelerator it bogs down and tries to stall out. i do have a high pitched whine coming from my fuel pump and when the van shuts off a sound like the fuel is surging back to the tank. could my fuel pump be causing the hard start and lack of power?

I have an intermitten problem of the fuel pressure dropping off and want to change the relay first to see if this fixes the problem. Where is it located on the 1996 Express 1500 van.