17
questions

I was installing a remote starter in my Corvette when I cut into the orange wire at the switch and I accidently touched the frame and I got a spark. The check engine light came on and I put my OBD11 on the car. I received a code of P0340 soI cleared the code and another code came up P0343. What can I do to fix my car? I do not know where to start can you please help me? I am not at all familiar with all this computer stuff. Thank you

The book says it is Camshaft Sensor A- Bank 1 Circuit High Input. it did have the code P0340 But now the code is P0343 and I have no idea what to look for. Can you help me Please? Thank You.

Thank you Sir I cleared the code and it came back. I even cleared it a second time and it did come back again. Do I need to check the fuses under the hood or in the drivers floor board? I called a Chevrolet shop and they told me that I needed to have it towed over to their shop. The serviceman told me it would probably start at $600.00 and or whatever it would take to get it back right. But that was just a guess and he would need it at his shop to evaluate the problem. How would I check or test those black box fuses in the fuse block area? Thank You

I was going to hook up a remote starter so I was skinning the orange wire for the accessory and my knife touched a piece of metal. It made a spark and the check engine light came on.I bought the OBD II to check to see what code I would get and it gave me the P0340 code.Did I blow a fuse or relay? The camshaft position sensor I know where it is but I was trying to follow the wiring and it goes to the PCM under the hood right side of engine compartment according to the internet. Did I burn up the PCM or can anyone point me in another direction. I want to fix it but I would like someone with experience to tell what I can do besides taking it to the Chevrolet shop. Please help me!

Where do the wires run from the camshaft positioning sensor to get it's voltage? Is it a fuse,relay or the box under the hood. I am trying to see where the camshaft positioning sensor is fed from or where it gets it's feed from. Please Help.

My Corvette takes longer to start,it will run rough a little bit and when I cut it off the starter will wind for several seconds before it starts back up. I bought an inexpensive model of the OBD11 when I hooked it up it gave me a code of P0343 camshaft position sensor A-Bank 1 Circuit High Input. Would it be better for me to test the voltage going to it first or is this common for these to go out? But I have to find it first. Please help me.Thank you

If I drive it to the grocery store three miles away and I try to start it up to go home the motor will just turn over and over. It takes three times for it to crank. Can anyone give me an idea what I need to do or look for.

Do I need to put a relay on the Vats wires with a resistor? Where are the Vats wires located? What color are the vats wires for a 2002 Corvette Coupe?I was trying to find a hook up and if anyone has one I could sure use it.All I want to do is hook up the remote starter and leave everything else alone. I have a Pursuit Series Model PRO-9776a.I took this one out of a 96 Corvette before I sold it.This hook up is a little different and I do not want to mess up my car.Can someone please help me.Thank you

turned engine light on at 59mph 1475rpm

Replaced fuses and bulbs even though they were okay all other lights work only the left and right brake lights won't come on

evry time i change the cooling fan fuse, it gose burne.
Ichanged that cooling fan but prublem still remain .thanks