The car drives ok.
No warning lights come on in the dash

Aveo 5 Lt 2009.second mo I owned it. blown head gasket. 3 RD mo struts/ bushings. Then oil leak.. flex pipe broke.. rear wheel bearings went out.. 02 sensors went.. thermostat needed .. replaced a . Ignition coil corroded.. replaced.. throttle repair. Thermostat housing leak around hoses and housing.. today was the clunking noise... eveyr time you ran over a hair line crack on the road. Now it needs sway bars.. what a joke this car has turned out to be.. GM should have recall on the whole car..this all within 3 years.. Sequel off the MONEY PIT with Tom Hanks.. monthly repairs is wrote on check memo on my check to shop.. you continue to look in your rearvw mirror to see if your leaving a part trail like bread crumbs so not to lose your way...Auto shop now serves you coffee with your hint of cream at the door upon your arrival.. and calls you by first name.. I HATE MY CAR. !!!!!!

Recently while driving to work in my 2009 aveo5 it began to run rough and the engine light came on. The engine light blinks while driving and burns steady while idling. I replaced the plugs, but didn't fix the problem. I had the local orielys run the codes today and it gave cylinder 2 misfire. Not sure where to start working. Please help.

My question is the car is under warranty, but they said that because need a maintanance of cleaning the fuel injectors was causing the HOLD Blinking on 3, which was causing the engine to work harder and the AC to stop blowing cool air. I think this is a scam to get charged a $200.00 plus maintance to clean the fuel injectors so the Hold button would work and then the AC will blow out cold air. They said if the HOLD BUTTON is blinking and stuck on 3, it makes the engine work harder and the AC not blow cold air, or shuts down. Please advise, I never heard of something with the fuel injector having to do anything with the AC....Nightmare of a day and they still havent fix the car, because they did not deliver some gasket...Please advise on the injector having to do with the fuel line and Hold button blinking and causing the AC not to cool...Is this correct? Hard to beleive, the car is only 3 years old and 30,000 miles...Jorge Sardinia