I know I pushed it once and hold lit up on dash. I was told it was to keep the wheels from spinning in winter weather but I don't think that is true.Please help thank youOHit has never came on unless it is pushed one time so far

The gas pump kept shutting off after every second or two. I was told it could be the purge valve? did code scans which indicated a problem with the fuel vapor canister.
Could someone possibly tell me what the possibilities are?

technician sounds like a computer geek. don't they belong at a computer not under the hood of my car

sat in rain for a day. went to drive to work and it spilled about an ice cream bucket of water through the dash. bought in november. had to replace heater motor think maybe same thing then froze in canadian winter. did first oil change and they didn't have cabinfilter so it doesn't currently have one. my other vehicles didn't have cabin air filters

So I was told the my rear bearings in my car are bad..but i dont think its is them.. everytime i hit a bump you can hear the back of my car like its slaming down on metal.. the guy quoted me on the part.. but wouldnt tell me that real name of the part.. he said that both sides needed to be done.. and that it was like 200 for the bearings and the frame.. I just want to know what the heck is wrong so i can look up the part my self..

told power steering flush wheel balance and fuel service recommended. Cant even find these in owners manuel Also multi point inspection and day I brought car home from dealer battery died. this is normal? really??

Turning air off, car runs a little smoother

The mechanic at the dealership servicing my 2007 Chevy Aveo5 says the front rotors need to be replaced because they are pocked and rusted. The car has 63,000 miles. What would you say about that? Should I try to get a refund from the manufacturer?

i am changing a timing belt on my 2007 chevy aveo. it has a 1.6 liter engine and is a 4 cylinder. i need the timing specs asap!!!!!

The car is a 2004 Aveo 5 (no choice above for that)that has been very well maintained. I have had all required service done at the proper intervals. It has 86,000 miles on it and I just had the front struts and rear shocks replaced. My mechanic says that he can find absolutely nothing else that needs to be done on the car. He could not identify the source of this noise. Can you help?