149
questions

I have oil leak betwen engen and gearbox its comming from gearbox <auto gearbox>

this happened 3 times already and it appears to be the same type of fuel line that was on it when i bought it. this last time it only lasted about 130 miles which was about 2 days

The car wouldnt hardly go after the light came on. It was like it was going to chock down. Rpms was up to like 5 and still was not going like it should.

When I was checking the radiator I found oil in the water. I checked and sure enough it appears as if the engine is venting oil into the radiator from someplace. Any ideas? A friend suggested it my be an oil cooler gone bad, there is no water in the engine The car doesn't smoke to I don't believe it is a head gasket, Any thoughts?

this occurs when i crank my vehicle up

I've been working this issue for some time now. I have cleaned the throttle body, idle control, replace all O2 sensors, The MAF, The MAP, cleaned the Fuel Injectors, replace the Temp sensor, replaced all air filters, all the airlines, the fuel filter and the pressure control valve. I cannot think what else I can do? I sent it to a Bosch shop and they couldn't figure it out. My Gas mileage is about 16.3mpg and it idles badly from the start but smooth’s out after about a minute. I really don't want to send it to the shop and was wondering if there are a couple of DIY things I can do before wasting my money at a Dealership. Thanks

Sometimes when at a sitting light, the car will just cut off or it vibrates.

why does my car say-40F and it beeps all the time what does it means

My AC quit working. Freon was added but leaked out.

Brake light and traction controls lights come on and brakes lock temporarily. Eventually lights go out.

looks like u can just pop it right back on or turn it to pop back on ?

the emissions code is po 365 could it be a defective part

Both front axle boots are torn. The cost quoted to repair was $413.71. What does it mean that they are torn?

It just happened, i was driving my BMW and suddenly the engine started shaking, all the lights on the dashboard came on, and the engine stopped. Now if i start the engine it does the same.I hope you can answer my question and thanks.

was this an update? am i missing a coolant bottle?recall?