Car starts and runs normally off idle but surges when returned to idle. I believe Crank sensor is okay. The problem happened after backing up to turn around and go downhill. I stalled the car while in reverse. It then started to roll down hill. I released the clutch (while still in reverse). I think the engine spun backwards a few times. I smelled strong odor of raw gasoline. I stopped and started it correctly. Check engine light came on (P0335), DSC (traction control) light came on, and brake light came on. All occurred after mishap

Could this be the battery dying or the starter I have no clue

I am now unable to attach pdf files in repair pal web site to my repairs. Before last week I was able to attach PDFs. what has happened now it says it cannot recognize the pdf that contain my receipts for repairs.

The battery is fine could it be clogged fuel pump

And when I put it on manual it goes back to normal

When I took the car into the shop I informed them that there was no air bag on that side. 2 hours later I picked up the car and drove home. I then noticed that they had put a sticker on the door frame that said there was no air bag on that side.
Why did they not replace the air bag at that time ?

It has a few other issues that will be costly, just wondering if I should just get rid of it without fixing it. If I put the money into it, will it be worth anything anyway?

It seems like it is only doing it when the air/defroster is on. I turned off the defroster and after a couple seconds it stopped, so I turned it back on, but it started again, then I turned it off, and again, it stopped....any thoughts?

I had a tune up not to long ago. I had 2 cylinders misfiring. I took the car out of town a few times and when i brought it back it would rattle a big and struggle to get out of first. Now i would step on the gas and struggle to get up to speed then get out of first. Now when i press the gas pedal the car wont accelerate.


my car was low on fluids and the mechanic put in 3 quarts of fluid the very same day my transmission seal broke. what would cause that? could he have overfilled it causing the seal to break?