The engine has no spark!

Inner handle was sticking. Cold weather. Need info to get door opened.

also the fans don't seem to be working can that be a problem to the cooling system?

What blew out? It's a 5 cylinder engine with 5 wire connections into holes on top of engine. Is my engine shot or repairable. Thank you for your help.

The front door locks will set off the car alarm when unlocking the door with the key. this tends to happen more often in the winter but has now become almost a constant irritation.

how difficult is it to put a new heat blower in my acura how long does it take n how much would it cost i know the part is like $175.00 but how much would it cost to fix it

The brake light sign on the dash board wont turn off. All the lights work and the brakes are great. I've replaced the light bulbs and cleaned the connectors but I cant get the light to stay off. When I start the engine the light is off but as soon as I hit the brakes the light stays on. Thanks PHE

On the passenger side (left) there is a engine part connected to a belt. My Acura dealer parts Dept. cannot indentify it. One person suggested it"s a smoke pump. It is starting to makes noise. Can you suggest a place to have it repaired, rather than disconnecting the belt? Thanks

My shifting between gears have become more difficult and I think my transmission fluid is old. What kind should I replace it with?

car not in use, fan goes on, drains battery. Put in new battery, new cable. Car in repair shop over one month and they cannot fix problem. Pls help thank you

fan under hood runs when car is not being used resulting in dead battery. Already put in brand new battery, new cable connection to battery. Car is in repair shop one month now (dealer) and they still cannot repair it. Pls help if you can. Thank you

Just recently purchased this vehicle and it just started having the problem of not being placed into drive without the aid of the key/shift lock mechanism. The manual says that if repeated use of this occurs we could damage the vehicle. I also have researched that this may be due to a solenoid and fuse problem (#1 and 39). Are there any other suggestions and or trouble shooting procedures you could recommend?