13
questions

i recently bought a 93 acura integra. the owners recently purchased a new distributor as they were experiencing timing issues. but instead of fixing the problem the car now wont start. when u turn the key the motor just keeps acting like it will start and it will idle for about a second and then it just keeps winding. need a recommendation on if i need to reinstall the distributor or if it could be another issue

only happens with 2nd and 3rd gear

93 integra special ls manual trans cruise button light comes on but no cruise light on dash gauge and cruise cannot be set

Only during the colder months, my key remains locked in the ignition & the Park indicator light does not illuminate. I have to wait about 5 minutes for the Park indicator to illuminate, which then allows me to remove the key. According to a Honda blog it could be a shift linkage problem. It’s a recall item on some types of Hondas. Why is this not a recall item on 1993 Integras? Any Ideas to fix the problem?

I've already WD40 the key & ignition and the Acura Dealer made a new factory key. Both without success.

Again, key removal is fine during warmer seasons.

Can 98 intgra stater fit a acura ls1993

where is the expansion value located. i think my mechanic is working on the wrong thing

one day i got out of the car and seat belt went forward like it should,and when i got back in the belt came back two inches and stoped. i pulled the 30 amp fuse for the drivers side retractor manually cranked the motor back.bad position switch? put the fuse back it returns to the forward position and wont return.

When i turn my car in the morning and i try to shift in reverse(automatic)it grinds and wont go in reverse but i let the car warm up and get the idle down and i try it again and most of the time it will shift into to reverse. The other day it started grinding while it was in parking in the morning...

s3 light blinks car wont start, replaced starter, battery, and did tune up.

My transmission is automatic. When the s3 light blinks the car will not start. It usually starts after 20 minutes but it is getting longer. last time it took 2 days.

heater blows when key is in aux but when u start the car it shuts off and won't turn back on so i jiggle the key while car is running and sometimes it comes back on radio is doing same thing

would like to know if it could be a bad relay switch anywhere if so where is the location of the relay

my battery light comes on when i run my accessories, i checked my alternator, starter, and battery. i have charge to all parts until i am driving my battery goes dead and i have to recharge it. what would i check next?