Mazda Tribute Problem Report

Mazda Tribute Stalling After Cold Start

(23 reports)

If the engine stalls after a cold start (the vehicle has been parked for a while), the idle air control (IAC) valve may be sticking. It may be fouled with carbon buildup. If cleaning the valve does not solve the problem, replacement will be needed.

Sometimes, I can not start the Tribute and after starting, it will die and come to a stop when slowing down at turns, stop signs or trafic light. It takes several tries to get it started again. I brought it in to a repair shop; however, they could not find any problem even afetr drivng it for two days and hooking it up to a computer. This sporatic problem has been going on for three months. I changed the fuel filter three times thinking that it was bad gas or trash in the fuel tank. The mechanic said that everything tested out okay on the computer with no problems with the fuel pump either. This problem is still tormenting me and my Tribute. -
The car would hesitate/sputter until it got up to temperature. The IAC was cleaned and another time it was replaced it resolved the problem. Now it's back again. -
Have had everything from cold start, to sputtering, stalling while driving and completely refusing to restart upon stalling. Computer, sensors, valves, gaskets, sparks and coils have all been changed in addition to a starter. The problem has yet to be resolved after two years! Once the suv is completely warmed, I have NO problems, but the check engine light remains on. -
When the car was parked for a long while it was difficult to get the engine to start and stay running. Had to press accelerator for a while to warm it up then would stay running while idling. -
car stalls when started up,after sitting for a few days. -
When the engine is cold, it start to fail, feels like of no have flow of fuel; after the engine reach the normal temperature it return to normal condition. I have change many sensors also ECU, and the problem still happning -
When I start the car on cold mornings it will idle fine. Engine stalls when trying to accelerate. -
Stalling when cold when foot taken off throttle. Starts again ok. UPDATE: Took off the IAC, cleaned out with some MAF cleaner and put back on. It's only stalled 3 times since then. It used to stall 90% of the time on start up. So IAC may be issue on some cars. -
same problem -
Same as EGR failure and Cold start stalling. Looking at intake replacement and EGR valve replacement. Causing me headaches, pain in my wallet and can't get an emissions test. :0( -
Related Items:
Every morning when the engine is cold and when the engine warms up for the day it runs great
Car was running fine, then one morning it did not want to start, sounded like a weak battery....
Problem only when cold. Have friend run codes with his machine and we have replace numerous pa...
replaced era&idle air control thats what the check engin light said to do.motor still doesent...
The problem begin after the big snow storm here at Willimantic CT.