GMC
Yukon
24

Speedometer or Other Instrument Panel Gauge May Work Erratically on GMC Yukon

Problem Description and Possible Solution

The speedometer or other instrument panel gauge may begin to work erratically at times. Our technicians tell us that the instrument cluster must be sent to a repair facility to correct this fault. The warranty has been extended on some of these units to 7 years or 70,000 miles.

Problem Data
RepairPal Verified
Average mileage: 115,510 (65,000–198,000)
7 model years affected: 1998, 2002, 2003, 2004, more2005, 2007, 2010
24 people reported this problem
Comments
Viewing 1 - 13 of 13 comments
Oil gauge, speedometer and gas gauges are acting erratic. I don't know if I have gas, if my oil is low or how fast in going. Please help.
Truck reads odometer error and the milage reset back to 94750 everytime the truck is restarted and Tire sensor error. With the tire dash light on. The engine hours read zero.
I just recently got the truck from my Dad's estate. The speedometer is buried past 120. The tach works when it wants to. Sometimes the fuel gage and or the alternator don't work right either! Or the oil pressure for that matter! Just researching to see where to go?
Speedometer and odometer and cruise control all stopped working simultaneously. Diagnosed by dealer to possibly be the cluster? $500-$600 estimated. I no longer use the cruise control and I use a GPS for my speedometer.
oil gauge stuck and not working
speed odometer problem cluster gear 500.00 fix on net. repair 50.00 fix
Gauges flip back and forth erratically, codes start showing one after another, power steering stops functioning, car may shut down (once while on the highway!). Have towed it to dealer several times and they cannot find the problem (all modules checked and cleaned). Will sometimes start and run fine for days, other times, it will repeat itself several times in one day or not start at all.

No solution yet - 7/22/16
Speedometer not registering correct speed, works erratically
Odometer stopped working after 10,000 miles
lost instrument cluster
it started with differant changes in the read at one point it would read 55 mph then i would drop to 10mph.. Now it just doent work at all
Speedometer reads 110 mph, but odometer still works. Gas gage points straight down
Speedometer reads 10mph below actual speed or in some instances stays at 0mph.