Close
496
questions

My manual shows a steering wheel switch, my vehicle does not have this switch. The light comes on a stays on without blinking.

replaced right rear calabor and pads and i can't get pressure back. how can i get the pressure in rear brakes

while at a dead stop and idling I'm getting a gas smell through the heat vents... any thoughts now I think I've a bad ignition coil could they be related problems THANKS in advance

Changed out all bulbs still can't get the drivers side break light to come on.

Certified Pre Owned
2012
purchased with 18K miles on the odometer.
No major repairs though I will be getting new tires next week.

I just bought this car and went for Inspection which failed because it says "on board computer system, OBD (Monitor Catalyst, Monitor EVAP, Monitor O2) not ready to be tested." Neither the technician nor anyone has an answer to this problem. Please help I need to register it soonest. Tnx.

My previous post was for the wrong year. I have a leak at front differential. One mechanic said the engine needs to be raised to repair it. What may be the cost of such a repair?

I have a front differential oil leak. One mechanic told me the engine needs to be raised to repair the leak (gasket?) What may be the cost of repairing such a leak?

My service manual only goes to 120,000 miles and I'm up to 125,000. Is there a suggested interval for timing belt replacement?

PO 441, PO 442 & PO446 are codes. Came on at same time at 114k miles. Tried gas cap tightened and can't see any detached vacuum lines.

What is an intermediate shaft and how important is it to me fixed and now difficult and evpencive.
2008 Toyota Highlander Sport

The screw behind the knob is okay and the control knob is still not working

I went on youtube to see if I could repair it myself but it shows a 3 knob panel. I have a 2 knob panel and it is all different and I have no idea as what to do . Can you help??????

at first it was occasionally it's a lot more often now

read fluid leaking under engine

have 149900 miles on my car, was driving home and suddenly sounded like drive shaft or something was dragging, looked under and nothing. before that the steering wheel would shake and then stop, then later it would happen again. when the car is put in R or D and other gears there is a chattering noise in the front connection of the drive shaft.

.the temperature does not change. It feels like the knob is stripped but it is not.

Mechanic says could be catalytic converter and O2 sensor, anyone else have this issue?

If so where is it located..

An intermittent check engine light that is on more that off these days. Changed gas cap with new OEM one. Engine seems to run fine.. smells a little rich on start up. 249,000 miles one my truck.. smog test comming in April. Where should I look?

It seems to have just started

1) Issue was a constant whine like a wheel bearing going out. Could hear at 20-25 mph, more prevalent at 45-50 and worse at 75+. Always coming from rear. Sound always the same (pitch didn't vary). Toyota had it for 13 days, replaced the front diff due to metal shavings in fluid. Problem still exists but now the pitch changes with speed (lower as the car slows down). Less noticeable at lower speeds. Car has 31k and under warranty. Thoughts? 2) We paid for an alignment after the diff replacement. I asked if it was a result of their work and they said "no". True? I wonder, but suspect it's true because the warranty would have paid for it to be done. Also, no noticeable wear on any of the tires although 3 were out. Steering wheel was straight (but not after the alignment). Thx!

Three auto body shops couldn't find the water leak coming from the frame.After a rain the car has a musty smell and we would like to know what company specializes in this problem.We live near houston texas'

Installed a new battery and these lights stay on now.

reason I went to 38 finish line for a quick oil change and carwash, the guy says, you need your radiator flushed? I said go for it. once its done, I had cold air coming out of my heater vents, goes away when hitting the gas peddle. took it back they add more antifreeze same issue, 2 days later end out having antifreeze leaking from the intake manifold, toyota say you need an engine. has anyone ever had this issue?
end out ordering a rebuilt engine and now looking for estimate installation.

When the key is on it shuts off. I tried disconnecting the motor at the switch on the motor and it shut off but the battery died. I pulled the relay and it shut off and the battery didnt die. I replaced the relay and had the same problem. Do you know what is causing this to happen?