1,471
questions

code reader said caticlac so I changed catlic converter but it still acts like someone shut off the gas while your driving and then after a minute turn it back on

Swapping motor an granny was wondering what models with the 2.0 would fit or if it had to b a forenza

Never reads current fuel level

The radiator is working getting hot top bottom and both sides but I can be backing up and it over heats then I have to wait 30 minutes to an hour for it to cool down with the car off and the heat on

.... sign when I press the eject button on the cd, all you hear is a eject sound but nothing else and also the window that's on the dash it doesn't show anything except for the passenger air bag, please help me fix it or give some pricing. thanks

has already been changed once by previous owner the head gasket that I bought has small holes for the water ports do they need to be enlarged to get better flow

location?

Engine light is on. traction signal on the dash board. Sometimes it jerks when slowing down to a stop.

We're looking for a nice used car for our daughter. She fell in love with a 2002 Suzuki Grand Vitara with only 61,000 miles on it. It's in GREAT condition on the exterior and interior. My husband doesn't want to get it because he thinks it will be too expensive to maintain. Opinions???

It overheats and it looses alot of fluids.

just replaced the engine ....
it is going above 1 km when idle ...
i am using a 11 plate battery ...

I have changed the coil, plugs and wires and reset timing and replaced cam sensor as well since it failed ohm testing and still will not startup completely... I am weaiting on OBD2 scan tool to read into it more and reset pcm...any suggestions? Idler pulley had blown and both have been replaced with no knocking , ping, good compression on all 4 cylinders...I have tried everything a PT shadetree can do - intereference motors i now know are a pain, but for $500 and clutch and breaks and transmissions done, i need it for my daughter to go to college.

But u can put in drive it will go but doesn't seem to shift ! Is it burnt clutches or bad sensors

When I start the engine, the sound is too loud. Sometimes it goes away after 1 min and sometimes I have to wait for up to 10 min for the sound to goes off.

There doesn't seem to be any specific speed or conditions to cause this. I'll be driving along and can tell from the sound that the o/d has turned off. Other than the sound of the engine there doesn't seem to be any noticeable difference in the way the car drives.It doesn't happen all the time, only occasionally.
Is there a relay or sensor that could cause this? Or, maybe a short in the wiring to the o/d light?

The blower motor did not shut off after removing the key. It operates now but the acc light stays on and by morning the battery is dead.

I have always had trouble with my low beams. If one burns out the other goes too. Recently I was told it was the switch but I could still turn on the high beams and my blinkers worked and I always use auto. so even if the switch went out they should still come one automatically I would think and if the switch broke wouldn't that also mean I wouldn't be able to switch to the highbeams.

The headlights flash sometimes an then sometimes they quit had the altanater checked an its good. When they start doing it, its like the motor pulses with the flashing of the lights. What could be the cause of this?

No matter if im driveing or parked i can not use my Ac or heat it shuts my car off if i turn it on

The gas pedal press and the speed meter moving but the car not moving