Close

Pontiac Sunfire Questions

Get answers to questions about your Pontiac Sunfire at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
519
questions

How do I have computer checked?

the transmission only shifts at high rpms. what is the possible causes?

What is my issue

Tested battery, tested starter , there is not even a click.

I replaced the cooling fan last week and in my city there is a lot of construction. I hit a wall in traffic again and cranked the heat up when it got about 6 hash marks above normal. I'm thinking the hum is from the belt and it may be a water pump issue. Revved it in park and it was humming then as well so not the tranny as it wasn't engaged at that point. Thanks for the help.

i recently replaced my heater core in a 2001 pontiac sunfire and now one the heater core hoses is leaking is it possible the heater core is not in stalled all the way thru the fire wall?

So, left my car running for a little over an hour one day. came back, turned it off. when i tried to start it back up nothing. Heres where im at. My shift clutch cable from the steering column to the clutch is shotty but ive rigged it before. (that issue was the car not turning from on to off. car would be stuck on, the cable was jamming, its usable now.) my clutch with the key on will not shift from park to anything, on the transmission case, the shift column i can force from park to reverse, but its tight and doesnt really want to, even in reverse, the clutch doesnt move from park. the car will not start. i am not getting spark to the plug, ive traced it back to the crankshaft sensor. it isnt getting voltage it needs to allow the ignition coils to jump. so ive got a car that now will not send voltage to the cps and will not shift. i know they have to be related. almost as if it thinks its stuck in a different gear and doesnt want to start. but locked itself up thinking it was shut off in park. its definetly something new and very obnoxious. anyway for me to atleast override the clutch so i can roll it home? (no i havent yet pulled the cable off to shift the transmission manually to neutral. not sure my brakes will like it or if the cable needs to be moved to neutal to allow a brake release) again, this is quite a strange issue.

I looked under the center counsel but found no adjusting screw/nut. Is there a way to adjust it?

where is emergency gear shift lever release? It should be on center console but I can't find it

it should be someplace on center console but i cna't find it

Can't even begin to get it to start. Motor just turns and turns

Engine just turns over. It don't even begin to fire

what causes this problem

I took out the ignition switch in my car but now the switch is locked in the column so I can't put it back together.

Cleared codes said OK but lights still on and seems like its going shut down. Anti theft, abs, brake, check engine all lights flash on? Almost seems like when shifting that's when abs and brake lights come on

Cleared codes said OK but lights still on and seems like its going shut down. Anti theft, abs, brake, check engine all lights flash on? Almost seems like when shifting that's when abs and brake lights come on

Cleared codes said OK but lights still on and seems like its going shut down. Anti theft, abs, brake, check engine all lights flash on? Almost seems like when shifting that's when abs and brake lights come on

Cleared codes said OK but lights still on and seems like its going shut down. Anti theft, abs, brake, check engine all lights flash on? Almost seems like when shifting that's when abs and brake lights come on

I have a 2003 sunfire 2.2 ecotec automatic lately it has been blowing the brake light and signal fuse. What would cause this. Also just today i was driving my car and not sure what happened but the transmission will not shift from second. It goes into park reverse and nutral perfectly just when i accellerate its stuck in second what would cause this please help

I have tried holding buttons 1 and 2 down together but the radio doesn't respond. I have also tried all the other 2 button combinations but still nothing. It will not give me a code. It just says "LOCKED" on the screen.