212
questions

Hiw to install a brake line properly?and where/how do i fix rear sriver side .

Just the left side of the car is leaking brake fluid.

I've changed the spark plugs twice, the coil and plugs while I changed the fuel filter my car got worse . So please help.

My 99 plymouth breeze break lights aren't working. Its not the fuses. All three lights just quit.

i was told it was due to a serpintine belt issue but i need to identify which belt it is.

Hello, here is my list of symptoms that I suspect can be caused by a faulty PCM but I'm no expert.
It all started when the battery light came on. After going to AdvancedAutoParts to check it out, the diagnostic was a bad regulator.
So I replaced the alternator, and later discovered that the regulator for this car was built in the PCM. (is that correct?)
After that I had a serie of electric wonder.

- the rear defroster came on and off randomly. I replaced the relay but it still did it. So I removed the relay becaused it's annoying.
- The speed of the intermittent wipers varies on their own. When set in one position, they can wipe 1 every 2 seconds, then 1 every 6, then continuous for 5 seconds, then every 3 seconds..
- There is a random damper sound closing and opening from center of the dashboard.
- When the ignition is on but engine off the radio is randomly scrambled but is fine when the engine is on.
- The cruise control works for 30 seconds then stops. The light on the dash stays on but that's it. If I turn the engine off and on again, it works again for another 30 seconds then stops.
- The auto power window goes down for seconds then stops. Push the button again and goes down for 2 seconds then stop...
- The engine has random jerks. I could be on the highway and the the ignition cuts of for a split second then it's fine.
- All the dash instrument would randomly drop very slighly just like they all lost power then come back on.
- The tachometer and miles display would lose power and come back on randomly.
- When I start up the car for the first time it would always stall once within 1 minute from starting up.
- The idle sometimes drops to the point it might stall but goes back to regular idle.
- The lights are flickering (dome light, headlights and dash LCD)

I think that's about all problems I have.
I pulled some codes P0700 and P0740 back in July.
The car has 244,000 miles.
So, is it sign of a bad PCM?
Thank you.

Location of the EGR
valve

Car won't start. no fire to coil or fuel pump

Brake lights and turn signals work but the tail lights do not.
Anyone know what would cause that?

My car didn't pass inspection. It shows a P0455 code: Evaporative Emission Control System Leak Detected (gross leak)
P0140: O2 Sensor Circuit No Activity Detected (Bank 1 Sensor 2). The O2 Sensor Circuit was recently repaired. What is the part that I need to repair so that my car will pass the emissions test and pass the inspection.

Noise seems to stop when braking and turning right.

I turned off and on the car a couple of times and there were a couple of time that the engine reved up the highest was 70. I finally went into reverse and I was able to drive it home. What could this mean. I switched out the head gasets, spark plugs and wires.

i try to do my own work on my car, i replace the crank sensor and the cam sensor, fuel pump is good, replaced the fuel filter it was time any way, checked the fuses and relays checked the coil, got codes 11 and 12 intermediate loss of power between the two sensors and the PCM, and or loss between the battery and the PCM, i was suppose to of driven to Oregon by now dont have the time or money to play elimination so any ideas

I replace the fuse each time and the 20A fuse blows again at ignition. One suggestion was to replace the engine to body grounding strap.

My car starts shaking and making a rattling noise when ever I push the breaks or push the has..yet when tested shows no codes but it is definitely overheated..if I just let it cool down you think it will start back up?