The snow that was had frozen my doors.I finally gotton the passager side opened,so when kept hit it,I've gotton it opened,however,the latch has alot of play,and now I have to go to the passager side to get in,but I can get out on the drivers side.What's wrong with the door?

Eversince my engine was put in,my car willn't start @ times,it's getting current from the battery,butwhen I turn the key,NOTHINGit's not the starter,battery.I'am going to do an test on it.What does it sounds like to YOU.My warrtery has run out on that engine.Thanks

The c/c sometimes willn't engaged.It will work for a bit,then it willn't.I've tried the fuses,it's ok.I've cut it off when I cut the car off,acted the same after it's turned the car back on.What else could it been?Is it something minor? Thanks

They said that both hoses were cold and he also said that my water pump was bad,but in the end all it needed was a fan motor,which was the same one from 1994 when the car was made;AC DELCO,now it running right.I'am very pleased with that,not only cause I work for them,but they took time to find and fixed the problem.Thanks for your input

car was working fine all of a sudden the steering got hard to turn,checked powersteering fluid and its full. also checked to see if my belt broke but its still there.

hecked fuses,ok,checked coolet,ok.When I'am driving @ high speeds;25-55mph,I can really feel it,but ideling,not that much,but feeling in the vents.What woulg cause that.It is trying to work it self out,clogged heater core,ect.What does it sound like its happening.Thanks

My heater does thorw out heat

Stopped working,two days ago.Coolet is full,it was working before the rebuilted motor was put in

It's making noise,but was working find,but now it's not

Take it to Meineke a yr ago and the braking system is find,but they said that a wire is hitting the abs sensor,and it was TSB on this issue with my kind of car,and 1994 Grind Prix,and one other car.They have to test the system,but they don't have the ols syle code reader @ that shop .what can be done?

My car got locked up and I took it to the shop. They tell me that the a/c compressor was spinning and broke and locked up the car. Can they just take it off and use a shorter serpentine belt?

Needed another engine for a 1994 Oldsmobile Cutlass Supreme S.I think that it's a 3.1lt.I heard that it could take 7-8 hours,including replacing all fliuds

My engine had coolet in the engine,and I had to get another one @ $954.00,MEINEKE will put it in.How much in labor will it cost me.How long will it take to put it in?My engine wasn't @ the shop cause someone didn't put it in the trailer,not have to wait extra week.Should they give me any discount on the labor because of the extra wait time?

I need to do this myself, I have some mechanical knowledge, I would like to know,is it under the upper manifold and is it very difficult to remove, meaning taking it out and replacing the gaskets

When I'am @ a light and getting ready to stop,and when I try to give it gas it will not go anywhere,but when I put it out of gear and back,it goes.Is this a vac leak,or some more like my transmission

Can not find a torqe rod for a 1994 Oldsmoblie Cutlass Supreme S,4 door.A few years ago,one broked,right side,was ordered,now the other side has broken,NOW I can't found that part anywhere'not even online.Outside of a junk yard,where could I get that.I found out that the same body style car,1994 Grand Prix,1994 Chevy Lum,may fit that.Will that work

When I restart it,put foot on brake and the light will not come on.Took it to the shop & he said that it was a TSB on my car,1994 Grand Prix,1994 Chevy Lum.a wire is hitting a sensor making it to come on.Have to use a scan tool to find out,but NO ONE has any scan tool that will fit;OB1

The fuel pump works. Oil light is on and check engine light is on.

had them both checkd and it was fine.They spray lube under it,but the noise got worse

The fuses are fine and the light bulbs are fine, so what else can it be?

At times it wont start after i drive it for a few hours shut it of and go to start it and it will turn over just not start. Got a code 0p300 any ideas what is causing this.

when i put it in drive it is starting in a higher gear. i can put it in first or second and it dosent shift. when i shift to third i get a shift and also in jus regular drive. i just had the transmission replaced so what can i do? its a 95 olds cutlass supreme 3.1

why is my car still running hot

car stalled out in water, started few hours later and ran ok but wouldn't rev higher than 3000rpms. After I drove a friend from Peterborough to buckhorn then drove back to Peterborough the car revved at 2200rpms on idle. Its important that I figure this out seeing as im not from Peterborough im simply working there for one more week. The roads downtown Peterborough were flooded during a severe thunderstorm Wednesday august 7

I stall when i sit at traffic lights the problem has got worse than before

Starts but after ten seconds it bogs down and dies

i do i find the crank censor to replace it because my car wont start up

the car will turn over but not start up i replaced the module now i am trying to repair the crank sensor

it makes this sound when its idling and when driving. gets faster when you accelerate

my 1997 Oldsmobile only when hot will randomly just stall as im driving seem to happen when it hot. I changed the crank sensor still happen now what no engine codes got any idears