The cars stops running try to turn it on again and it won't

put a dirty MAF sensor make the car die.

runs fine for 2 or 3 miles starts bugging losing power then just stalls wont start back up for about an hourthen two or three miles it stalls again

It slowly will gain momentum but sounds like it's RPMs are really high. It will stay in all gears. Checked the gear oil and was full.

How much for the transmission? Tires? Windshield?


my car is a nissan Tiida, 2006 Model, % door Visia.My car doesnt wanna start it keeps on stolling .The engine is turning but doesnt start.I checked the petrol pump and it seems fine.

I just had a front ball bearing replaced and a CV axel. It took 4 trips to the mechanic to get it right. It's a 1997 with 162,000 miles on it.
The vehicle has more wheel issues like the back brake cylinder. It's hard to know whether it is time to give it up and spend savings on something newer or to continue to invest in this Nissan. Your experiences with these situations would be appreciated.

I'm considering doing this replacement on my own, any tips or tools I should use.

What could be causing this? Every time I start it

Car ran great when I shut it off next morning it would only turn over, so far I've replaced the fuel pump and the filter, still won't start. No fuel going to the motor. Will start for a second or two when using starting fluid.

What els could show the same symptom poor idle want crank when warm and car dies when put in gear

The car idles but when I try to move forwards or backwards it dies when warm idle dies

it drove fine untill hitting a rock on the road it starts fine all normal no lights on just wont go when you put in gear you can feel it trys to but as you press on throttle more it hessitates please help any information helps

It's a XE and it does it while on the road

Only my passenger side front window is not working. It works for a few days then stops working. I have been trying to keep it closed buy someone accidently opened it. What should I check?

My car suddenly began stalling while in reverse and would cut off. A few weeks later the Check engine light came on so I went to AutoZone to get a diagnostic and found that my sensors needed replaced so my father and brother replaced them as they were worn. But it doesn't cut off anymore while in drive at traffic lights, but now again, only in reverse. It will idle down and it's stalls so I have to hit the gas to reverse, as it sputters and cuts off. What could be the issue?

I can hear the engine strain when the a/c is turned on but no air through the vents.

I can't get any more than 2300 rpm's

Need a solution to solve the exhaust vibrations when the car is idle or in traffic

Starts up as the day cools down. Doesn't make any movements just a slight clik from the ignition relay.I changed the starter and the but I still have the same problem.

My dad just gave me this car a week ago, everything was good when he checked it and was doing good. Last night on the way home it just all of a sudden cut off, we coasted to the side to check everything, but we couldn't find anything wrong with it. We tried push starting, but that didn't even work. The ignition won't even turn over. Nothing is working, except when you put the key in, it makes the annoying beeping noise other than that not even the radio will come on.