Nissan Sentra Questions

All Nissan Sentra Questions

Ask a Question
I have had the tie rods axles and struts checked. I do notice some noise when going over bumps. The noise when steering is like a popping or grumpling sound i can feel it by my pedals.
The gas in my tank leak out when it's sitting in front of my door, and, it spit the gas back out when I'm trying to fill up my tank. When I took my car to the mechanic, he said a code came up that my crankshaft positi...
Number 2 cylinder is missfiring and spark plugs have been replaced, one of which showed fowled.Wehicle still skipping, but but noticably less tn before replacing spark plugs. Want to know how the coil pack can be test...
I have had to replaced the engine last year and the fuel pump yesterday and it's still not running
over the past 8 months the car takes spells that it will Not crank. I let the car sit for 7 weeks at first. Then one day it cranked. Then it will not. Have changed plugs, coil pack and cam sensor. Car still in a will ...
I am due for an oil change and it knocks faster with car speed but does stop periodically on long straight-aways. As soon as I start again it begins to knock.
My transmission seems to be giving me trouble with driving. The car makes lots of noises when driving and at times is not able to be put into drive. I can only go in reverse when this happens. Is this a transmission p...
I change parts on my car and the light is on.
Car just started cutting off while I was driving! mostly apon stopping or pulling off from a stop. Did the daily sometimes several times a day for week then engine light came on 81,000 miles..any ideas..did a check on...
Vehicle has a warning light on panel which looks like a horseshoe, or possibly a headset, with an exclamation point on the inside.
It's usually when I'm trying to steer around something or backing out of the drive. When I turn real sharp it makes a loud popping sound under the front end.
i have changed all 4 oxygen sensors and replaced the flex pipe. i am still getting obd2 codes po 430 and po153 without the engine light on. what next should i try?