I'm having trouble with the left turn it doesn't seem to go all the way that it should the right turn goes all the way like it should I can do a U-turn but I can't do a U-turn with my left going to the left

parking lock will not engage, cannot remove ignition key and steering sill not lock

My vehicle has been overheating, water seems to be leaking from the manifold? Is there a small hose somewhere between the intake manifold and engine? Started noticing about 2 days ago, occurs when pressure is built up

My hill parking break light comes on. And stays on when driving or park. Also it's a sound like something is being let out sounds like air but tire is fine coming from rear

The check engine light is on, also.


When handed the Fail certificate for my 2002 Montero Sport 3.5L from the smog station, I went straight to Pep Boys for the Bank 2 Sensor 2 02 sensor specified on the paperwork as being faulty. With the Bosch 13801 sensor in hand, I went home and got to work. The plug didn't line up exactly with the insert, so I broke of a little plastic lip on the Bosch, and slipped it in.
Alas, the check engine light keeps coming back on. Twice I've disconnected the battery for 20 minutes. Though the memory is wiped out, the radio continues to work, and doesn't need to be rebooted with a code.
Any insight would be helpful. Thanks!

I edino,i a a challenge with my jeep, the engine is having a thick sound, from normal sound and on the dashboard the battery light and break light is on when the car is on, also my stirring is very Steve to turn. Plus what is the course off all this problems. Edithompson2004@yahoo.com

Heating up the gauge goes all the way up and comes down then goes up again

My flexplate/flywheel is bad in my 2000 mitsubishi montero sport. I replaced the starter and shortly afterward it began grinding again, now it is failing to engage sporadically. I did this repair on a 72 ford F-100 years ago and am curious what I need to know that may be different when changing it in this newer model

Code P0401 still exist, I cleared the code several times, checked the solenoid related to EGR valve, the EGR itself cleaned and its working normal, all related tubes are good, no leaks, there is constant 12 volt exist at EGR solenoid when turning the ignition switch on position, and goes away after couple of seconds when switched off. Any suggestion or more to look? Thank you.

How much depression should the ac belt have after installing the nee belt

Grinds when I got bumps

It smokes when idling. I get no smoke at all while driving. The smoke is black and not heavy. I just wanted to know if this is something I can fix myself or do I need to take it to a mechanic? If I am able to do it, How do I go about doing that?

Didnt start till about 30 miles later wjy is this happing

says Ecm pam. no longer available from mitsubishi. no one sales fuel sensor

We are at a red light and the car idels low and then stalls

Shifts going up hill no power behind it has problems needs help but why would it run like that... Torch converter??

To chang spark plugs

there's voltage at coils