Close

Mercury Mountaineer Questions

Get answers to questions about your Mercury Mountaineer at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
876
questions

Why does my mountaineer turn off while its idling and will not start again

It wont pass emissions it says faulty 3 and 4

Runs idle but dies out when mashing on vas

It has been running ruff for some time have replaced a lot of things. I have a code reader and it hasn't said anything and the check engine light hasn't come on.

Took it to Auto Zone and they said it was the Thermostat. Even took to a dealer and they said same thing. Well we replace the upper and lower housing and reset light. After about 2 days of driving it was back. Took back to get hooked up and again said the Thermostat. We replaced it again all in about 2 months. What are we missing here? It also has a lil sputter when idling. We have changed spark plugs and wires, filters and oil. HELP PLEASE!

Cluster lights not always on headlights not turning off and radio display malfunctioning not turning on

Now it's popping louder and the wheel ( on the front driver side) is starting to shake and the steering as well

This ford dealership is trying to charge me 160 for a diagnostic and I already had that done at another autobody for 80. And they're telling me that it will cost me 600 or better for an instrument cluster!I haven't had my vehicle for a year and a half yet and feel I'm being railroaded!

It is a 4.6 v8

ibaci check fuse and its fine. How to reset sencer?

The prior owner of the truck said that he put a starter on it and it was the wrong one so he had to order the correct one and when he got it and put it on the truck was just sitting up and it caused the computer to jump time or something but he said he was told that a test could be ran n they would start back

1998 mercury mountaineer third brake light flickers oil pressure gage fluctuates abs light stays on making it very hard to come to a stop. These things have started happening one by one within ththe last week or two.

It pulls left and right with a humming sound anywhere I drive it is an r title and the check advance trac is on but im not sure if it has to do with that or is it my transmission slipping and its really bad once ive driven it for about 10 minutes on until it cools down again

I hear a popping and it feels like its coming from the rear tires

The squealing is much louder and distinctly different than the common belt chirp. It's difficult to narrow down to the specific pulley just by listening to the squealing. Based on research, I'm guessing it's the idler pulley, but just wanted to educated opinions in order to avoid unnecessary time and money being used for things that aren't in need of repair.

Had my transmission looked at the fluid is clean a sensor replaced but it's still slipping the fluid is clean but it is shaking the whole truck I think it's something in the front end but people keep telling me the transmission is slipping love your phone and doesn't work right I would imagine the torque converters having trouble can you help me with this question

or disconnect it?

I recently had transission rebuilt for $1900 and its not making any outside noise, not breaks or front cv joint its coming from driver side rear tire, no winding or clinking/ticking is heard when turning from the outside and no warning of this.

I don't have the $ to fix, priced around (600-1200) is there anything I can do (troubleshoot) short time?