Jaguar XJ8 Questions

All Jaguar XJ8 Questions

Ask a Question
was running fine before I parked it for two weeks and battery went dead.
I get a signal to check brake light. The left brake light bulb is out. Both the bulb and fuse are good. When I press the brake petal I hear a click by the shift lever. Any ideas on what going on?
Discovered car with lights flashing after sitting for 3 days. Put key in ignition and started up & lights stopped flashing. Turned off and lights started again. Tried to restart would not start but engine would cra...
Happens every time is used, do not know if it will cool or sweat it
the car started this morning no problem but when I stopped and switched off and came back the car opened with remote put key in ignition all lights came on but engine would not turn over, then I tried to lock it up ...
I had only travel about 2 1/2 miles from home. I was able to turn around before the engine shutdown and will not crank. It has 101,486 miles on it. I have replaced the battery and new sun roof. I had the following rep...
I have a new High Mount assembly to install on our 2002 Jaguar XJ8, but I cannot discover how to access the plug which seems to be below the rear glass deck. I tried through the trunk via the gas tank cover, but there...
Working backwards: 1)This morning when turning the ignition switch all the dashboard lights flash and the headlights flash along with a clicking noise but the engine won't turn over. 2) Yesterday the warning message...
I just last week replaced alternator and battery at dealer, 3 days driving and now this happens. The loud click/snap is coming from engine compartment, seems like from underside of engine.
I need to get the hood open and I have no idea how to get the passenger side to release. this just happened today
Having issues with the fuel pump and I want to eliminate this part from the checks
not play even after following instructions of "wait / code" several times. Disconnected and tried several more times still won't play. Added disc player in trunk has power but will not play either? Help!!!
However it still doesn't work. It has happened in the past and all of a sudden it works. I looked like a hero in the past because it started working while I had the car. So now my wife is asking what did you do last...
However it still doesn't work. It has happened in the past and all of a sudden it works. I looked like a hero in the past because it started working while I had the car. So now my wife is asking what did you do last...
I see 2 lines but I can only hook up to one of them and it seems to be the high side. is this the correct line? I am unable to see witch line goes to the compressor. I also could be looking at the wrong lines..
I'm just wondering if my transmission is shifting correctly; my car registers 2400 rpm at 70 mph; it seems a little high; what should it be? Maybe I'm spoiled by my wife's 2013 XF which is only 1800 rpm at 75 mph!
had front end checked out appeared ok, what could it be
I parked my car yesterday and then tried to start it and it would only run for a few seconds and it ran rough those few seconds. The check engine light and battery light was on during those few seconds. I don't know...
engine light on all the time. Restrictive performance goes on and off.
It is a toggle switch that seems to engage disengage on it's own. Driving and turned off. There is no fuse for this. This has been a small problem until now. It just seems to get worse.