60
questions

Rebuilt transmission as of 6/2013

on my 2004 Isuzu axiom

And now the old one will not work what can I do

When pushing Auto it's green, but when you push defrost for front or back, there is a red light. I realized no heat is coming in.

How do I find out life average of 2002 Isuzu Axiom.

I have a 2004 Isuzue Axion with 149K miles on it. A few weeks back I started experiencing engine sputtering, loss of power, with the check engine light coming on. The local shop replaced the wires, new OEM spark plugs, etc, so essentially a tune-up. The light did not come o any more.

A week later, the light comes on again, with the P0302, cylinder #2 misfiring. The Axiom has all the classic symptoms of sputtering and loss of power when driving.

The shop replaced the coil packs, all the obvious stuff, but no luck in fixing the problem.

I took it to another shop, and they initially estimated an $800 to $900 repair bill. The shop then called me back, saying that some bolts had gotten loose in the engine causing major damage. To reattach the plates, the estimate was $400. To repair the engine, with no guarantee of the work, was $2500. I authorized the $400 repair.

The Axion still sputters. Here is what was listed on the service order:

CUSTOMER STATES “CHECK ENGINE LIGHT” LIGHT, ROUGH, MISFIRE

PHONE OK FOR DIAGNOSTICS INCLUDING TEARDOWN

COMPUTER MANAGEMENT SYSTEMS ANALYSIS,WITH ENGINE PERFORMANCE TESTS, P0302

COMPRESSION & CYLINDER LEAKAGE TESTS

R & I THE UPPER INTAKE MANIFOLD

I FOUND THE AIR PLATES AND THE PLENUM LOOSE *& SEVERAL BOLTS WERE INJESTED INTO THE ENGINE.

REPAIR/TIGHTEN THE LOOSE AIR INTAKE PLATES IN THE PLENUM

ENGINE VALVE DAMAGE IN THE #2 CYLINDER

About a month ago, the satellite symbol on the display unit disappeared, also the clock and compass no longer works (only shows dashes.) How & where can this be repaired?

I'm thinking about buying an Isuzu 2004 Axiom, and I would like to know what the most common problems with a 2004 Isuzus Axiom are. anyone?

Ineed lock out from the cylinder.can I do with broken key.I'm broke

I got into my vehicle this morning the car felt like it wanted to cut off and the engine light was flashing. I drove only down about 4 blocks and turned around and came back home the light went off for a few seconds and then came back on flashing again. I've just had my starter replaced yesterday and was not having this problem before.

We have had to change the ignition control module in the past and have changed it just this week since it's not ran. Not sure what else we can do?

My car seemed to drive okay on the way & when I arrived. At lunch time..started my car & the light has not flashed again, even on the drive home. Should I be concerned or do I need to follow this up? Thanks in advance.

I have put in a new battery and had autozone test the alternator. Per them it is charging correctly. But as I'm driving down the road. I lose all my electrical. The radio goes out, the heater goes out and gages go dead. The car stills runs but only for a couple of minutes. then the car stops running. I have to hook up jumpercables to get the car started. It will run for a little while but then do the same thing over and over again. WHY???

Four wheel drive will not stay engaged after accelerating. What could case this in this vehicle? The indicator light comes when the vehicle is put in four wheel drive and then as you begin rolling it turns off. Thoughts and ideas. Thanks

Earlier this year I replaced the EGR sensor, O2 sensors,plugs and boots. There are no mechanics in this small town that know anything about this car/truck, so I do all repairs myself. When these parts have an issue it tells the engine not to run so they must be replaced, I'd like to know what would cause these parts to not work I do have a computer hook up that gives me codes and it says these parts are the problem again. Any answer would be great, auto repairs here think I should junk my car but I can't do that and they didn't like the fact that I fixed it on my own, being female they can't stand it when I'm right. She isn't junk, there isn't an isuzu dealer or repair around here.

I just drove my 2002 Izuzu Axiom on a 1,000 mile road trip. Mid-way through the drive as I was pulling away from a gas station, I noticed first gear would not engage and the RPMs would soar when I tried to hit the gas from a stop. It also made a weird noise, like the gear was trying to catch but was just rubbing. Once I got going about 10 mph (and I'm assuming in 2nd gear), the car was fine and I drove the rest of the way. Reverse works fine as well. I bought the car with 120K miles on it and it now has 126K. I haven't had the transmission fluid checked since I bought it and I'm not sure the last time the previous owner had it checked. It looks like transmission issues are a common area that people get taken advantage of, so I wanted to get a little background before hearing back from the repair shop. Any advice is much appreciated, thanks in advance!

Not all the time but when I go around curves

I was told by a mechanic to watch out of that

I use 5w-30 oil, 1000km it is normal to consume 1L oil.

After being away for the weekend, the battery was dead (no interior lights.........nothing) and the car would not start on Monday morning. It ran good on the previous Friday before we left. There was just a loud clicking noise when turning the key while trying to jump the battery.

since i am in Cameroon and bought this Used Axiom, the mechanics could not solve the problem. so i have pack the car. I love it and want it repaired and restored to its real strength. thanks

ISUZU SERVICE HAS REPROGRAMMED IT AND DO NOT KNOW WHAT ELSE TO DO. CAR IS DIAGNOSED AND FINE EVERYTHING. CODE STAYS P0602 AND NOT GOES AWAY.
VEHICLE DIES IN MINUTES WHEN IT STARTS TO DRIVE, ALL LIGHTS ARE ON COMING SUDENLY, ABS, CHECK ENGINE, TRANSMISSION, BATTERY AND CAR WHEN DIES. PAID $$$$ FOR TOWING. HELP PLEASE SOMEBODY!!

The part is supposed to come from Germany and still hasn't come in.

sometimes it will engage, other times I have to jiggle the shifter while trying to press in the button. When I finally do get it into gear my TOD light starts flashing, but not always & it will shut off usually by turning off the car and restarting it. HELP!!!

red battery light on dash when auto is running
what does it indicate

I have to push the knob in to release the lever several times and often use both hands. Once out of park, the lever moves easily from gear to gear (reverse to drive, etc). Is there an easy remedy, or does this require a mechanic. If it does need to go to the shop, can you give a general estimate of what I should expect to pay?

Thanks so much for your help.